【HDU】1372 Knight Moves

Problem Description A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the “difficult” part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

 

Input The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 

 

Output For each test case, print one line saying “To get from xx to yy takes n knight moves.”. 

 

Sample Input

e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6  

Sample Output

To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.

一道很经典的bfs题目,方向有八个,使用<queue>

代码:

//
//  main.cpp
//  1372
//
//  Created by showlo on 2018/5/20.
//  Copyright © 2018年 showlo. All rights reserved.
//

#include <iostream>
#include <queue>
using namespace std;
int s1,s2,e1,e2;
int map[8][8];
int dirx[8]={2,1,-1,-2,-2,-1,1,2};
int diry[8]={1,2,2,1,-1,-2,-2,-1};

int check(int x,int y){
    if(x<0||x>7||y<0||y>7)
        return 0;
    else
        return 1;
}
int bfs(){
    int x,y,xx,yy;
    memset(map, 0, sizeof(map));
    queue<int> q;
    q.push(s1);
    q.push(s2);
    while (!q.empty()) {
        x=q.front();
        q.pop();
        y=q.front();
        q.pop();
        if(x==e1&&y==e2)   //到达目的点
            return map[x][y];
        for (int i=0; i<8; i++) {
            xx=x+dirx[i];
            yy=y+diry[i];
            if (check(xx, yy)==0||map[xx][yy]>0)
                continue;
            map[xx][yy]=map[x][y]+1;
            //cout<<xx<<yy<<endl;
            q.push(xx);
            q.push(yy);
        }
    }
    return 0;
}

int main() {
    char a[3],b[3];
    int step;
    while (cin>>a>>b) {
        s1=a[0]-'a';
        s2=a[1]-'1';
        e1=b[0]-'a';
        e2=b[1]-'1';
        step=bfs();
        cout<<"To get from "<<a<<" to "<<b<<" takes "<<step<<" knight moves."<<endl;
    }
    return 0;
}

    原文作者:骑士周游问题
    原文地址: https://blog.csdn.net/biongbiongdou/article/details/80380783
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞