L3-014. 周游世界
周游世界是件浪漫事,但规划旅行路线就不一定了…… 全世界有成千上万条航线、铁路线、大巴线,令人眼花缭乱。所以旅行社会选择部分运输公司组成联盟,每家公司提供一条线路,然后帮助客户规划由联盟内企业支持的旅行路线。本题就要求你帮旅行社实现一个自动规划路线的程序,使得对任何给定的起点和终点,可以找出最顺畅的路线。所谓“最顺畅”,首先是指中途经停站最少;如果经停站一样多,则取需要换乘线路次数最少的路线。
输入格式:
输入在第一行给出一个正整数N(<= 100),即联盟公司的数量。接下来有N行,第i行(i=1, …, N)描述了第i家公司所提供的线路。格式为:
M S[1] S[2] … S[M]
其中M(<= 100)是经停站的数量,S[i](i=1, …, M)是经停站的编号(由4位0-9的数字组成)。这里假设每条线路都是简单的一条可以双向运行的链路,并且输入保证是按照正确的经停顺序给出的 —— 也就是说,任意一对相邻的S[i]和S[i+1](i=1, …, M-1)之间都不存在其他经停站点。我们称相邻站点之间的线路为一个运营区间,每个运营区间只承包给一家公司。环线是有可能存在的,但不会不经停任何中间站点就从出发地回到出发地。当然,不同公司的线路是可能在某些站点有交叉的,这些站点就是客户的换乘点,我们假设任意换乘点涉及的不同公司的线路都不超过5条。
在描述了联盟线路之后,题目将给出一个正整数K(<= 10),随后K行,每行给出一位客户的需求,即始发地的编号和目的地的编号,中间以一空格分隔。
输出格式:
处理每一位客户的需求。如果没有现成的线路可以使其到达目的地,就在一行中输出“Sorry, no line is available.”;如果目的地可达,则首先在一行中输出最顺畅路线的经停站数量(始发地和目的地不包括在内),然后按下列格式给出旅行路线:
Go by the line of company #X1 from S1 to S2. Go by the line of company #X2 from S2 to S3. ......
其中Xi是线路承包公司的编号,Si是经停站的编号。但必须只输出始发地、换乘点和目的地,不能输出中间的经停站。题目保证满足要求的路线是唯一的。
输入样例:
4 7 1001 3212 1003 1204 1005 1306 7797 9 9988 2333 1204 2006 2005 2004 2003 2302 2001 13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011 4 6666 8432 4011 1306 4 3011 3013 6666 2001 2004 3001 2222 6666
输出样例:
2 Go by the line of company #3 from 3011 to 3013. 10 Go by the line of company #4 from 6666 to 1306. Go by the line of company #3 from 1306 to 2302. Go by the line of company #2 from 2302 to 2001. 6 Go by the line of company #2 from 2004 to 1204. Go by the line of company #1 from 1204 to 1306. Go by the line of company #3 from 1306 to 3001. Sorry, no line is available.
//Dijkstra算法求最短路的变形
#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <vector>
#define M 0x3f3f3f3f
using namespace std;
struct node{//前向星存图
int to;
int next;
}edge[20500];
struct node1{
int to,dis,pre,num;//点,距离,前一个点,换乘次数
node1(int a,int b,int c,int d):to(a),dis(b),pre(c),num(d){}
bool operator< (const node1 &b)const{
if(this->dis!=b.dis){
return this->dis>b.dis;
}
else{
return this->num>b.num;
}
}
};
int cnt,head[10000],com[10000][10000];//com记录公司线路编号
void Add(int x,int y){
cnt++;
edge[cnt].to=y;
edge[cnt].next=head[x];
head[x]=cnt;
}
void Dijkstra(int x,int y){
int book[10000],distance[10000],number[10000],previous[10000];//标记,距离更新,换乘次数,路径前一个点
priority_queue<node1> q;
memset(book,0,sizeof(book));
memset(number,0,sizeof(number));
memset(distance,M,sizeof(distance));
distance[x]=0;
q.push(node1(x,0,0,0));
while(!q.empty()){
node1 h=q.top();
q.pop();
if(book[h.to]){
continue;
}
book[h.to]=1;
for(int i=head[h.to];i;i=edge[i].next){
if(distance[edge[i].to]>distance[h.to]+1){
distance[edge[i].to]=distance[h.to]+1;
int t=(h.to==x?0:h.num+(com[h.pre][h.to]!=com[h.to][edge[i].to]));
q.push(node1(edge[i].to,distance[edge[i].to],h.to,t));
previous[edge[i].to]=h.to;
number[edge[i].to]=t;
}
else if(distance[edge[i].to]==distance[h.to]+1&&number[edge[i].to]>h.num+(com[h.pre][h.to]!=com[h.to][edge[i].to])){
q.push(node1(edge[i].to,distance[edge[i].to],h.to,h.num+(com[h.pre][h.to]!=com[h.to][edge[i].to])));
previous[edge[i].to]=h.to;
number[edge[i].to]=h.num+(com[h.pre][h.to]!=com[h.to][edge[i].to]);
}
}
}
if(distance[y]==M){//没有现成的线路可以使其到达目的地
printf("Sorry, no line is available.\n");
return;
}
//打印经停站数量,路径
int now=y;
vector<int> v,re;
v.clear();
v.push_back(y);
while(now!=x){
int t=previous[now];
v.push_back(t);
now=t;
}
re.clear();
re.push_back(x);
for(int i=v.size()-2;i>=1;i--){
int a=v[i],b=v[i+1],c=v[i-1];
if(com[b][a]!=com[a][c]){
re.push_back(a);
re.push_back(com[b][a]);
re.push_back(a);
}
}
re.push_back(y);
re.push_back(com[previous[y]][y]);
printf("%d\n",distance[y]);
for(int i=0;i<re.size();i+=3){
printf("Go by the line of company #%d from %04d to %04d.\n",re[i+2],re[i],re[i+1]);
}
return;
}
int main(){
int x,y,n,m,k;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d%d",&m,&x);
for(int j=1;j<m;j++){
scanf("%d",&y);
Add(x,y);
Add(y,x);
com[x][y]=com[y][x]=i;
x=y;
}
}
scanf("%d",&k);
for(int i=1;i<=k;i++){
scanf("%d%d",&x,&y);
Dijkstra(x,y);
}
return 0;
}