Currency Exchange(Bellman_ford算法)

原题链接
Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 27166 Accepted: 10058
Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA – exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.
Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output

YES
Source

Northeastern Europe 2001, Northern Subregion
题意:这里有N种货币,分别记为1~N,有M种货币交换的方式,每一种方式有A,B两种钱币,有RAB, CAB, RBA and CBA,四个数,表示交换率, Nick手上有其中的一种货币S,货币S的钱数为V,问你能否通过一定次数的钱币交换让Nick手中的钱增加
所以只要图中存在一个正环能使得通过循环这个环使得数不停地变大,那么就肯定是YES了

//http://poj.org/problem?id=1860
#include <algorithm>
#include <iostream>
#include <utility>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
using namespace std;

typedef long long ll;
const int MOD = int(1e9) + 7;
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
const ll INFF = 0x3f3f3f3f3f3f3f3fLL;
const double EPS = 1e-9;
const double OO = 1e20;
const double PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=100 + 5;
struct edge{int x,y;double rxy,cxy,ryx,cyx;};
int n,m,s;
double money;
edge E[maxn];
double d[maxn];
bool Bellman_ford(){
        memset(d,0,sizeof(d));
        d[s]=money;
        //循环这么多次也只是为了保证能将所有增大的值都传递了
        for(int i=0;i<n;i++){
                for(int j=0;j<m;j++){
                        edge t=E[j];
                        if( d[t.y] < (d[t.x] - t.cxy)*t.rxy ) d[t.y] = (d[t.x] - t.cxy)*t.rxy;
                        if( d[t.x] < (d[t.y] - t.cyx)*t.ryx ) d[t.x] = (d[t.y] - t.cyx)*t.ryx;
                }
        }
        //一旦有一个边是仍然可以增大的那么就说明存在正环
        for(int i=0;i<m;i++){
                edge t=E[i];
                if(d[t.y] < (d[t.x] - t.cxy)*t.rxy || d[t.x] < (d[t.y] - t.cyx)*t.ryx) return true;
        }
        //如果全都不能增大那自然是不存在正环的
        return false;
}
int main(){
        cin >> n >> m >> s >> money;
        for(int i=0;i<m;i++)
                cin>>E[i].x>>E[i].y>>E[i].rxy>>E[i].cxy>>E[i].ryx>>E[i].cyx;
        if(Bellman_ford()) cout << "YES" << endl;
        else cout << "NO" << endl;
        return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/qq_31805821/article/details/52419992
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞