POJ 2151 Check the difficulty of problems(概率DP)

Check the difficulty of problems

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3191 Accepted: 1416

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石   以其把这题归入概率DP,不如就归入DP类。因为此题虽然是求概率,但是和其他的概率DP不同。做法就是简单的DP做法。 解释见注释:

/*
POJ 2151
题意:
ACM比赛中,共M道题,T个队,pij表示第i队解出第j题的概率
问 每队至少解出一题且冠军队至少解出N道题的概率。

解析:DP
设dp[i][j][k]表示第i个队在前j道题中解出k道的概率
则:
dp[i][j][k]=dp[i][j-1][k-1]*p[j][k]+dp[i][j-1][k]*(1-p[j][k]);
先初始化算出dp[i][0][0]和dp[i][j][0];
设s[i][k]表示第i队做出的题小于等于k的概率
则s[i][k]=dp[i][M][0]+dp[i][M][1]+``````+dp[i][M][k];

则每个队至少做出一道题概率为P1=(1-s[1][0])*(1-s[2][0])*```(1-s[T][0]);
每个队做出的题数都在1~N-1的概率为P2=(s[1][N-1]-s[1][0])*(s[2][N-1]-s[2][0])*```(s[T][N-1]-s[T][0]);

最后的答案就是P1-P2
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
using namespace std;

double dp[1010][50][50];
double s[1010][50];
double p[1010][50];
int main()
{
    int M,N,T;
    while(scanf("%d%d%d",&M,&T,&N)!=EOF)
    {
        if(M==0&&T==0&&N==0)break;
        for(int i=1;i<=T;i++)
          for(int j=1;j<=M;j++)
           scanf("%lf",&p[i][j]);
        for(int i=1;i<=T;i++)
        {
            dp[i][0][0]=1;
            for(int j=1;j<=M;j++)dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);

            for(int j=1;j<=M;j++)
              for(int k=1;k<=j;k++)
                dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);

            s[i][0]=dp[i][M][0];
            for(int k=1;k<=M;k++)s[i][k]=s[i][k-1]+dp[i][M][k];
        }
        double P1=1;
        double P2=1;
        for(int i=1;i<=T;i++)
        {
            P1*=(1-s[i][0]);
            P2*=(s[i][N-1]-s[i][0]);
        }
        printf("%.3lf\n",P1-P2);
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/10/03/2711164.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞