POJ 1611 The Suspects (并查集,简单)

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 17128 Accepted: 8254

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003       简单的并查集题目。 直接合并,统计和0一起的结点个数。  

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;

const int MAXN=30010;
int F[MAXN];
int num[MAXN];
int find(int x)
{
    if(F[x]==-1)return x;
    return F[x]=find(F[x]);
}
void bing(int x,int y)
{
    int t1=find(x);
    int t2=find(y);
    if(t1!=t2)
    {
        F[t1]=t2;
        num[t2]+=num[t1];
    }
}
int main()
{
    int n,m;
    int k;
    int a,a0;
    while(scanf("%d%d",&n,&m)==2)
    {
        if(n==0 && m==0)break;
        for(int i=0;i<n;i++)
        {
            F[i]=-1;
            num[i]=1;
        }
        while(m--)
        {
            scanf("%d",&k);
            for(int i=0;i<k;i++)
            {
                if(i==0)scanf("%d",&a0);
                else
                {
                    scanf("%d",&a);
                    bing(a,a0);
                }
            }
        }
        printf("%d\n",num[find(0)]);
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2013/04/02/2996405.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞