POJ 2923 Relocation (状态压缩+DP)

Relocation

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1106 Accepted: 447

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

Source

TUD Programming Contest 2006, Darmstadt, Germany     状态压缩+DP 好题

/*
POJ  2923
解法为状态压缩DP+背包,
本题的解题思路是先枚举选择若干个时的状态,
总状态量为1<<n,判断这些状态集合里的那些物品能否一次就
运走,如果能运走,那就把这个状态看成一个物品。预处理完能
从枚举中找到tot个物品,再用这tol个物品中没有交集
(也就是两个状态不能同时含有一个物品)的物品进
行01背包,每个物品的体积是state[i],价值是1,求
包含n个物品的最少价值也就是dp[(1<<n)-1](dp[i]表示状态i需要运的最少次数)。

状态转移方程:dp[j|k] = min(dp[j|k],dp[k]+1) (k为state[i,1<=j<=(1<<n)-1])。
算法复杂度O((2^N)*N)


*/

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
const int INF=0x3f3f3f3f;
int state[1030];
int tol;
int dp[1030];
int n,C1,C2;
int cost[110];
bool vis[1030];

bool judge(int x)
{
    int sum=0;
    memset(vis,false,sizeof(vis));
    vis[0]=true;
    for(int i=0;i<n;i++)
    {
        if((1<<i)&x)
        {
            sum+=cost[i];
            for(int j=C1;j>=cost[i];j--)
              if(vis[j-cost[i]])
                 vis[j]=true;
        }
    }
    if(sum>C1+C2)return false;
    for(int i=0;i<=C1;i++)
      if(vis[i]&&sum-i<=C2)
        return true;
    return false;
}
int main()
{
    int T;
    int iCase=0;
    scanf("%d",&T);
    while(T--)
    {
        iCase++;
        scanf("%d%d%d",&n,&C1,&C2);
        for(int i=0;i<n;i++)
          scanf("%d",&cost[i]);
        for(int i=0;i<(1<<n);i++)dp[i]=INF;
        dp[0]=0;
        tol=0;
        for(int i=1;i<(1<<n);i++)
          if(judge(i))
            state[tol++]=i;
        for(int i=0;i<tol;i++)
          for(int j=(1<<n)-1;j>=0;j--)
          {
              if(dp[j]==INF)continue;
              if((j&state[i])==0)
              {
                  dp[j|state[i]]=min(dp[j|state[i]],dp[j]+1);
              }
          }
        printf("Scenario #%d:\n%d\n\n",iCase,dp[(1<<n)-1]);
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/14/2685430.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞