题目来源:http://codeup.cn/problem.php?cid=100000582&pid=2
感谢晴神的《算法笔记》
题目描述
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
输入
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
输出
For each test case, print the winning number in a line. If there is no winner, print “None” instead.
样例输入
7 5 31 5 88 67 88 17 5 888 666 666 888 888
样例输出
31 None
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
using namespace std;
void clear(queue<int>& q) {
queue<int> empty;
swap(empty, q);
}
int main()
{
queue<int> unique;
set<int> list_1,list_2;
int N;
while(cin>>N){
while(N--){
int t;
cin>>t;
if((!unique.empty()) && unique.front()==t){
unique.pop();
while((!unique.empty()) && list_2.find(unique.front())!=list_2.end())
unique.pop();
}
if(list_1.find(t)!=list_1.end()){
list_2.insert(t);
}
else {
list_1.insert(t);
unique.push(t);
}
}
if(unique.empty())
cout<<"None"<<endl;
else
cout<<unique.front()<<endl;
list_1.clear();
list_2.clear();
clear(unique);
}
return 0;
}