L3-014. 周游世界
时间限制 200 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序
Standard 作者 陈越
周游世界是件浪漫事,但规划旅行路线就不一定了…… 全世界有成千上万条航线、铁路线、大巴线,令人眼花缭乱。所以旅行社会选择部分运输公司组成联盟,每家公司提供一条线路,然后帮助客户规划由联盟内企业支持的旅行路线。本题就要求你帮旅行社实现一个自动规划路线的程序,使得对任何给定的起点和终点,可以找出最顺畅的路线。所谓“最顺畅”,首先是指中途经停站最少;如果经停站一样多,则取需要换乘线路次数最少的路线。
输入格式:
输入在第一行给出一个正整数N(<= 100),即联盟公司的数量。接下来有N行,第i行(i=1, …, N)描述了第i家公司所提供的线路。格式为:
M S[1] S[2] … S[M]
其中M(<= 100)是经停站的数量,S[i](i=1, …, M)是经停站的编号(由4位0-9的数字组成)。这里假设每条线路都是简单的一条可以双向运行的链路,并且输入保证是按照正确的经停顺序给出的 —— 也就是说,任意一对相邻的S[i]和S[i+1](i=1, …, M-1)之间都不存在其他经停站点。我们称相邻站点之间的线路为一个运营区间,每个运营区间只承包给一家公司。环线是有可能存在的,但不会不经停任何中间站点就从出发地回到出发地。当然,不同公司的线路是可能在某些站点有交叉的,这些站点就是客户的换乘点,我们假设任意换乘点涉及的不同公司的线路都不超过5条。
在描述了联盟线路之后,题目将给出一个正整数K(<= 10),随后K行,每行给出一位客户的需求,即始发地的编号和目的地的编号,中间以一空格分隔。
输出格式:
处理每一位客户的需求。如果没有现成的线路可以使其到达目的地,就在一行中输出“Sorry, no line is available.”;如果目的地可达,则首先在一行中输出最顺畅路线的经停站数量(始发地和目的地不包括在内),然后按下列格式给出旅行路线:
Go by the line of company #X1 from S1 to S2. Go by the line of company #X2 from S2 to S3. ......
其中Xi是线路承包公司的编号,Si是经停站的编号。但必须只输出始发地、换乘点和目的地,不能输出中间的经停站。题目保证满足要求的路线是唯一的。
输入样例:
4 7 1001 3212 1003 1204 1005 1306 7797 9 9988 2333 1204 2006 2005 2004 2003 2302 2001 13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011 4 6666 8432 4011 1306 4 3011 3013 6666 2001 2004 3001 2222 6666
输出样例:
2 Go by the line of company #3 from 3011 to 3013. 10 Go by the line of company #4 from 6666 to 1306. Go by the line of company #3 from 1306 to 2302. Go by the line of company #2 from 2302 to 2001. 6 Go by the line of company #2 from 2004 to 1204. Go by the line of company #1 from 1204 to 1306. Go by the line of company #3 from 1306 to 3001. Sorry, no line is available.
题意是给你一张图,这张图里有若干个节点,若干条边。其中有M条线路(线路就是由若干个相邻边组成的),然后给出K个查询,每个查询给出起点和终点,要打印出经过节点最少的线路,如果有结果不唯一,则打印要换乘线路最少的那条。
考查多标尺最短路。一般优先用SPFA,也可以使用Dijkstra。需要注意这么几个地方:
1.本题N的上限是1W,不方便用邻接矩阵存图(内存太大),所以这里用vector邻接表
2.经过提交,原生Dijkstra会超时,应该使用堆优化的Dijkstra或SPFA
3.如何区分图里的不同线路是个难点,没想到啥好办法,我开了个大数组做标记
4.注意打印的格式要求,打印每条路的起点和终点(换乘点),然后再打印下一条路
5.如果你只得了24分,可能是打印节点的时候没有加前导0(比如有个节点是1号,你应该打印0001,而不是1)
#include <cstdio>
#include <vector>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <queue>
#define MAX 10000 + 10
#define INF 0x3fffffff
using namespace std;
vector<int> MGraph[MAX];
vector<int> path[MAX];
vector<int> tempPath;
vector<int> bestPath;
int cnt = INF;
int rote[MAX][MAX];
int visit[MAX];
int dist[MAX];
typedef struct {
int u;
int value;
} Node;
bool operator > ( const Node &a, const Node &b ) {
return a.value > b.value;
}
void Dijkstra( int start, int end ) {
cnt = INF;
for( int i = 0; i < MAX; i++ ) path[i].clear();
tempPath.clear();
bestPath.clear();
fill( visit, visit + MAX, 0 );
fill( dist, dist + MAX, INF );
dist[start] = 0;
/*
for( int i = 0; i < MAX; i++ ) {
int u = -1, MIN = INF;
for( int j = 0; j < MAX; j++ ) {
if( !visit[j] && dist[j] < MIN ) {
u = j;
MIN = dist[j];
}
}
if( u == -1 ) return;
visit[u] = 1;
for( int j = 0; j < MGraph[u].size(); j++ ) {
int v = MGraph[u][j];
if( !visit[v] && dist[u] + 1 < dist[v] ) {
dist[v] = dist[u] + 1;
path[v].clear();
path[v].push_back( u );
}
else if( !visit[v] && dist[u] + 1 == dist[v] ) {
path[v].push_back( u );
}
}
}
*/
priority_queue<Node, vector<Node>, greater<Node> > q;
Node node;
node.u = start;
node.value = dist[start];
q.push( node );
while( !q.empty() ) {
Node cur = q.top();
q.pop();
int u = cur.u;
if( visit[u] ) continue;
visit[u] = 1;
for( int j = 0; j < MGraph[u].size(); j++ ) {
int v = MGraph[u][j];
if( !visit[v] && dist[u] + 1 < dist[v] ) {
dist[v] = dist[u] + 1;
path[v].clear();
path[v].push_back( u );
Node node;
node.u = v;
node.value = dist[v];
q.push( node );
}
else if( !visit[v] && dist[u] + 1 == dist[v] ) {
path[v].push_back( u );
}
}
}
}
void dfs( int v, int s ) {
if( v == s ) {
tempPath.push_back( s );
int pre = -1;
int sum = 0;
vector<int> curPath;
for( int i = 0; i < tempPath.size() - 1; i++ ) {
int a = tempPath[i];
int b = tempPath[i + 1];
int cur = rote[a][b];
if( cur != pre ) {
sum++;
//printf( "%d\n", cur );
//curPath.push_back( id );
}
pre = cur;
}
if( sum < cnt ) {
cnt = sum;
bestPath = tempPath;
}
tempPath.pop_back();
return;
}
tempPath.push_back( v );
for( int i = 0; i < path[v].size(); i++ ) {
dfs( path[v][i], s );
}
tempPath.pop_back();
}
int main() {
int n;
scanf( "%d", &n );
for( int i = 1; i <= n; i++ ) {
int m, id, pre, cur;
scanf( "%d", &m );
pre = cur = -1;
for( int j = 0; j < m; j++ ) {
scanf( "%d", &cur );
if( pre != -1 ) {
MGraph[pre].push_back( cur );
MGraph[cur].push_back( pre );
rote[cur][pre] = rote[pre][cur] = i;
}
pre = cur;
}
}
int q, start, end;
scanf( "%d", &q );
for( int i = 0; i < q; i++ ) {
scanf( "%d%d", &start, &end );
Dijkstra( start, end );
dfs( end, start );
if( dist[end] == INF ) {
printf( "Sorry, no line is available.\n" );
}
else {
int len = bestPath.size();
int pre = -1;
printf( "%d\n", dist[end] );
for( int i = len - 1; i > 0; i-- ) {
int a = bestPath[i];
int b = bestPath[i - 1];
int cur = rote[a][b];
if( cur != pre ) {
if( pre == -1 ) {
printf( "Go by the line of company #%d from %04d ", cur, a );
}
else {
printf( "to %04d.\n", a );
printf( "Go by the line of company #%d from %04d ", cur, a );
}
}
//printf( "%d %d %d\n", a, b, cur );
pre = cur;
}
printf( "to %04d.\n", bestPath[0] );
}
}
return 0;
}