POJ 2488

A Knight’s Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 52258 Accepted: 17725

Description

《POJ 2488》Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

大致题意:

给出一个国际棋盘的大小,判断马能否不重复的走过所有格,并记录下其中按字典序排列的第一种路径。

经典的“骑士游历”问题,DFS水题一道

解题思路:

难度不大,但要注意:

1、 题目要求以”lexicographically”方式输出,也就是字典序…要以字典序输出路径,

那么搜索的方向(我的程序是path()函数)就要以特殊的顺序排列了…

这样只要每次从dfs(A,1)开始搜索,第一个成功遍历的路径一定是以字典序排列…

下图是搜索的次序,马的位置为当前位置,序号格为测试下一步的位置的测试先后顺序

按这个顺序测试,那么第一次成功周游的顺序就是字典序

《POJ 2488》

2、国际象棋的棋盘,行为数字p;列为字母q

 

#include <iostream>
#include <string.h>
 
using namespace std;
#define size 30
int k=1,n,m,flag;
int visit[size][size];
int dx[10]={-2,-2,-1,-1, 1,1, 2,2};
int dy[10]={-1, 1,-2, 2,-2,2,-1,1};
struct node{
    int x,y;
}str[size];
void dfs(int row,int col,int step)
{
    if(flag==1){
        return;
    }
    visit[row][col]=1;
    str[step].x=row;
    str[step].y=col;
    if(step==n*m){
        flag=1;
        cout<<"Scenario #"<<k++<<":"<<endl;
        for(int i=1;i<=n*m;i++){
            cout<<char(str[i].x-1+'A')<<str[i].y;
        }
        cout<<endl<<endl;
        return;
    }
    for(int i=0;i<8;i++){
        int nex=row+dx[i];
        int ney=col+dy[i];
        if(nex<=m&&nex>=1
           &&ney<=n&&ney>=1
           &&!visit[nex][ney]){
            dfs(nex,ney,step+1);
        }
    }
    visit[row][col]=0;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(visit,0,sizeof(visit));
        flag=0;
        cin>>n>>m;
        dfs(1,1,1);
        if(!flag){
            cout<<"Scenario #"<<k++<<":"<<endl;
            cout<<"impossible"<<endl<<endl;
        }
    }
    return 0;
}

 

    原文作者:骑士周游问题
    原文地址: https://blog.csdn.net/qq_40421671/article/details/83117647
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞