[搜索] POJ 3984 迷宫问题

 

迷宫问题

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7620 Accepted: 4466

Description

定义一个二维数组:

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

 

 

题目解析:这题算是搜索里面的简单题了吧,题目也很好理解,就是找到最短的路径出去,并输出0所在的位置;想说的是,暴力搜索的时候,注意边界,我做到现在所有的dfs,bfs,都要在固定范围内进行搜索。然后是进行逐个的搜索,其实也不难理解的。具体的看看代码,自己多理解一点吧!

 

本题也可以用dfs来做,在输出坐标时会比bfs更好控制。这次用的结构体做的bfs。之所以用结构体,是因为要输出0所在的位置,也就是便于控制(x,y)的坐标~~

 

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
using namespace std;
int a[101][101];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
struct node{
 int x,y,pre;
}q[101];
void print(int i){
 if(q[i].pre!=-1){
  print(q[i].pre);
  cout<<"("<<q[i].x<<","<<" "<<q[i].y<<")"<<endl;
 }
}
void bfs(int x1,int y1){
 int front=0,rear=1,m,n;
 q[front].x=x1;
 q[front].y=y1;
 q[front].pre=-1;
 while(front<rear){
  for(int i=0;i<4;i++){
   m=q[front].x+dx[i];
   n=q[front].y+dy[i];
   if(m<0||n<0||m>4||n>4||a[m][n])
    continue;
   else{
    a[m][n]=1;
    q[rear].x=m;
    q[rear].y=n;
    q[rear].pre=front;
    rear++;
   }
   if(m==4&&n==4) print(front);
  }
  front++;
 }
}
int main(){
 int i,j;
 memset(a,0,sizeof(a));
 for(i=0;i<5;i++)
  for(j=0;j<5;j++)
   cin>>a[i][j];
 cout<<"(0, 0)"<<endl;
 bfs(0,0);
 cout<<"(4, 4)"<<endl;
 return 0;
}

    原文作者:迷宫问题
    原文地址: https://blog.csdn.net/tlonline/article/details/38037169
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞