A Knight’s Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40636 Accepted: 13807
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
题目意思是:从所给棋盘的第一个位置出发,深度优先搜索棋盘,但是每一次搜索都有八个方向,注意方向也得按照字典序,就是按照马走日的方法,不重复遍历,判断能不能把这个棋盘给遍历完成。博客里的代码大部分都是借鉴别人的,想把这些方法总结起来。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;
int visited[27][27];
int p, q;//p指列指数字,q指行指字母
int flag;
int path[27][2];//记录路径
int dir[8][2] = { -2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1 };//指八个方向
void build(int a,int b)
{
int i, j;
for (i = 1;i <= b;i++)
for (j = 1;j <= a;j++)
visited[i][j] = 0;
}
void dfs(int a,int b,int step)//step记录步数
{
if (flag)return;
path[step][0] = a;
path[step][1] = b;
if (step==p*q)
{
flag = 1;
return;
}
for (int i = 0;i < 8;i++)
{
int nx, ny;
nx = a + dir[i][0];
ny = b + dir[i][1];
if (nx >= 1 && nx <= q&&ny >= 1 && ny <= p&&!visited[nx][ny])
{
visited[nx][ny] = 1;
dfs(nx, ny, step + 1);
visited[nx][ny]=0;//如果上一次搜索未能成功,返回到上一步,把该处的状态返回原样
}
}
return;
}
int main()
{
int n,i;
cin >> n;
for (i = 1;i <= n;i++)
{
cin >> p;
cin >> q;
build(p,q);
memset(path, 0, sizeof(path));
flag = 0;
visited[1][1] = 1;
dfs(1,1,1);
cout << "Scenario #" << i <<":"<< endl;
if (flag)
{
for (int j = 1;j <= p*q;j++)
printf("%c%d", path[j][0] - 1 + 'A', path[j][1]);
printf("\n");
}
else
printf("impossible\n");
if(i!=n)
printf("\n");
}
}