PAT L3-014. 周游世界

L3-014. 周游世界

时间限制 200 ms

内存限制 65536 kB

代码长度限制 8000 B

判题程序
Standard 作者 陈越

周游世界是件浪漫事,但规划旅行路线就不一定了…… 全世界有成千上万条航线、铁路线、大巴线,令人眼花缭乱。所以旅行社会选择部分运输公司组成联盟,每家公司提供一条线路,然后帮助客户规划由联盟内企业支持的旅行路线。本题就要求你帮旅行社实现一个自动规划路线的程序,使得对任何给定的起点和终点,可以找出最顺畅的路线。所谓“最顺畅”,首先是指中途经停站最少;如果经停站一样多,则取需要换乘线路次数最少的路线。

输入格式:

输入在第一行给出一个正整数N(<= 100),即联盟公司的数量。接下来有N行,第i行(i=1, …, N)描述了第i家公司所提供的线路。格式为:

M S[1] S[2] … S[M]

其中M(<= 100)是经停站的数量,S[i](i=1, …, M)是经停站的编号(由4位0-9的数字组成)。这里假设每条线路都是简单的一条可以双向运行的链路,并且输入保证是按照正确的经停顺序给出的 —— 也就是说,任意一对相邻的S[i]和S[i+1](i=1, …, M-1)之间都不存在其他经停站点。我们称相邻站点之间的线路为一个运营区间,每个运营区间只承包给一家公司。环线是有可能存在的,但不会不经停任何中间站点就从出发地回到出发地。当然,不同公司的线路是可能在某些站点有交叉的,这些站点就是客户的换乘点,我们假设任意换乘点涉及的不同公司的线路都不超过5条。

在描述了联盟线路之后,题目将给出一个正整数K(<= 10),随后K行,每行给出一位客户的需求,即始发地的编号和目的地的编号,中间以一空格分隔。

输出格式:

处理每一位客户的需求。如果没有现成的线路可以使其到达目的地,就在一行中输出“Sorry, no line is available.”;如果目的地可达,则首先在一行中输出最顺畅路线的经停站数量(始发地和目的地不包括在内),然后按下列格式给出旅行路线:

Go by the line of company #X1 from S1 to S2.
Go by the line of company #X2 from S2 to S3.
......

其中Xi是线路承包公司的编号,Si是经停站的编号。但必须只输出始发地、换乘点和目的地,不能输出中间的经停站。题目保证满足要求的路线是唯一的。

输入样例:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
4
3011 3013
6666 2001
2004 3001
2222 6666

输出样例:

2
Go by the line of company #3 from 3011 to 3013.
10
Go by the line of company #4 from 6666 to 1306.
Go by the line of company #3 from 1306 to 2302.
Go by the line of company #2 from 2302 to 2001.
6
Go by the line of company #2 from 2004 to 1204.
Go by the line of company #1 from 1204 to 1306.
Go by the line of company #3 from 1306 to 3001.
Sorry, no line is available.

提交代码

感觉网上写的都太复杂,就自己瞎几把写了个.

#include <bits/stdc++.h>
using namespace std;
vector<int>g[10005];
map<int,map<int,int> >mp; //记录一条路线的编号 二维map不会爆内存
int min1,min2;//路线最少,换乘最少.
int vis[10005]; //回溯标记
int pre[10005];  //记录前驱
stack<int>q;   //将长度最小的路径压入
int road[10005];  // 最后的路径
int road1[10005];  //相同站数不同换乘的数组.
int flag;  //是否可以到达
int len;  //路径的长度
int check(int road[]) {
    int x=mp[road[0]][road[1]];
    int cnt=1;
    for(int i=0; i<len; i++) {
        if(mp[road[i]][road[i+1]]!=x&&i+1<len) {
            x=mp[road[i]][road[i+1]];
            cnt++;
        }
    }
    return cnt;
}
void dfs(int st,int ed,int cnt) {
    if(((st==ed &&cnt<min1 )||(st==ed&&cnt==min1))) {
        flag=1;
        min1=cnt;
        q.push(ed);
        while(pre[ed]!=-1) {
            q.push(pre[ed]);
            ed=pre[ed];
        }
        if(q.size()<len) {
            len=0;
            while(!q.empty()) {
                road[len++]=q.top();
                q.pop();
            }
        } else if(q.size()==len) {
            int len1=0;
            while(!q.empty()) {
                road1[len1++]=q.top();
                q.pop();
            }
            if(check(road1)<check(road)) {
                for(int i=0; i<len1; i++)
                    road[i]=road1[i];
            }
        }
        return;
    }
    int sz=g[st].size();
    for(int i=0; i<sz; i++) {
        int v=g[st][i];
        if(!vis[v]) {
            vis[v]=1;
            pre[v]=st;
            dfs(v,ed,cnt+1);
            vis[v]=0;
            pre[v]=-1;
        }
    }
}
int main() {
    int n;
    while(cin>>n) {
        for(int i=0; i<10005; i++)
            g[i].clear();
        mp.clear();
        for(int i=1; i<=n; i++) {
            int m;
            cin>>m;
            int num[105];
            for(int j=0; j<m; j++) {
                cin>>num[j];
            }
            for(int j=0; j<m-1; j++) {
                g[num[j]].push_back(num[j+1]);
                g[num[j+1]].push_back(num[j]);
                mp[num[j]][num[j+1]]=i;
                mp[num[j+1]][num[j]]=i;
            }
        }
        int k;
        cin>>k;
        while(k--) {
            int a,b;
            cin>>a>>b;
            min1=99999;
            min2=99999;
            while(!q.empty())
                q.pop();
            memset(pre,-1,sizeof(pre));
            memset(vis,0,sizeof(vis));
            len=99999999;
            vis[a]=1;
            flag=0;
            dfs(a,b,0);
            if(!flag) {
                cout<<"Sorry, no line is available."<<endl;
                continue;
            }
            cout<<len-1<<endl;
            int x=mp[road[0]][road[1]];
            int st=0;
            for(int i=0; i<len; i++) {
                if(mp[road[i]][road[i+1]]!=x&&i+1<len) {
                    printf("Go by the line of company #%d from %04d to %04d.\n",x,road[st],road[i]);
                    x=mp[road[i]][road[i+1]];
                    st=i;
                }
            }
            printf("Go by the line of company #%d from %04d to %04d.\n",x,road[st],road[len-1]);
        }
    }
    return 0;
}

    原文作者:骑士周游问题
    原文地址: https://blog.csdn.net/sky_miange/article/details/69218858
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞