Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
int path[90][90], vis[90][90];
int p, q, cnt, flag;
int dx[8]={-1,1,-2,2,-2,2,-1,1};
int dy[8]={-2,-2,-1,-1,1,1,2,2};
int check(int x, int y)
{
if (x>=1&&x<=p&&y>=1&&y<=q&&vis[x][y]==0&&flag==0)
return 1;
return 0;
}
void dfs(int r, int c, int step)
{
path[step][0]=r;
path[step][1]=c;
if (step==p*q){
flag=1;
return;
}
for (int i=0; i<8; i++){
int nx=r+dx[i];
int ny=c+dy[i];
if (check(nx, ny)){
vis[nx][ny]=1;
dfs(nx, ny, step+1);
vis[nx][ny]=0;
}
}
}
int main()
{
int n, cas=0;
scanf("%d", &n);
while (n--){
flag=0;
scanf("%d%d", &p, &q);
memset(vis, 0, sizeof(vis));
vis[1][1]=1;
dfs(1, 1, 1);
printf("Scenario #%d:\n", ++cas);
if (flag){
for (int i=1; i<=p*q; i++)
printf("%c%d", path[i][1]-1+'A', path[i][0]);
}else
printf("impossible");
printf("\n");
if (n!=0)
printf("\n");
}
return 0;
}