POJ 4127:迷宫问题

题目

总时间限制: 1000ms 内存限制: 65536kB
描述
定义一个二维数组:
int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

输入
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
输出
左上角到右下角的最短路径,格式如样例所示。
样例输入
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
样例输出
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路

BFS,用dict记录下来路径,反向遍历即可。

代码

while True:
    try:
        grid = []
        for _ in range(5):
            grid.append(list(input().split()))
        path_dict = {}
        path_dict[0, 0] = [-1, -1]
        queue = []
        queue.append([0, 0])
        directions = [[-1, 0], [1, 0], [0, 1], [0, -1]]
        visited = [[0 for i in range(5)] for j in range(5)] visited[0][0] = 1 while len(queue): top = queue[0] queue.pop(0) if top[0] == 4 and top[1] == 4: tmp_list = [] tmp_list.append([4,4]) next_pos = path_dict[4, 4] while not next_pos[0] == -1 and not next_pos[1] == -1: tmp_list.append([next_pos[0], next_pos[1]])
                    next_pos = path_dict[next_pos[0], next_pos[1]]
                for i in range(len(tmp_list))[::-1]:
                    print('({0}, {1})'.format(tmp_list[i][0], tmp_list[i][1]))
                break
            for direction in directions:
                new_r = top[0] + direction[0]
                new_c = top[1] + direction[1]
                if new_r >= 0 and new_r < 5 and new_c >= 0 and new_c < 5 and not visited[new_r][new_c] and grid[new_r][new_c] == '0':
                    path_dict[new_r, new_c] = [top[0], top[1]]
                    visited[new_r][new_c] = 1
                    queue.append([new_r, new_c])
    except:
        break
    原文作者:迷宫问题
    原文地址: https://blog.csdn.net/y12345678904/article/details/79090909
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞