习题:杨辉三角
杨辉三角是二项式系数在三角形中的一种几何排列。它的每个数等于它上方两数之和,每行数字左右对称,由1 开始逐渐变大。
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
请求出杨辉三角的第 n 行,第m 项的数字是什么。
输入格式
第一行输入两个整数 n,m代表行数和列数。(1≤n,m≤50)
输出格式
输出一个整数,代表杨辉三角的第 n 行,第 m 项的数字。
样例输入
6 3
样例输出
10
之前这道题我是用递归做的,但是它一到大数就会超时。
import java.util.Scanner;
public class ex50 {
static int n,m;
static int f(int n,int m){
if(n==m||m==1)
return 1;
else
return f(n-1,m-1)+f(n-1,m);
}
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in=new Scanner(System.in);
n=in.nextInt();
m=in.nextInt();
System.out.println(f(n,m));
}
}
下面是用递推做的,带大数溜溜的。
import java.util.Scanner;
public class ex49 {
//递推
static int n,m;
static long[][] f=new long[60][60];
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in=new Scanner(System.in);
n=in.nextInt();
m=in.nextInt();
f[1][1]=1;
f[n][1]=1;
f[n][n]=1;
for(int i=2;i<=50;i++)
for(int j=1;j<=i;j++){
f[i][j]=f[i-1][j-1]+f[i-1][j];
}
System.out.println(f[n][m]);}
}