最少转弯问题(又是BFS,但就喜欢用矩阵)

问题 J: 最少转弯问题

题目描述

给出一张地图,这张地图被分为n×mn,m<=100)个方块,任何一个方块不是平地就是高山。平地可以通过,高山则不能。现在你处在地图的(x1,y1)这块平地,问:你至少需要拐几个弯才能到达目的地(x2,y2)?你只能沿着水平和垂直方向的平地上行进,拐弯次数就等于行进方向的改变(从水平到垂直或从垂直到水平)的次数。例如:如图,最少的拐弯次数为5

输入

1行:n   m

2n+1行:整个地图地形描述(0:空地;1:高山),

如(图)第2行地形描述为:1 0 0 0 0 1 0

              3行地形描述为:0 0 1 0 1 0 0

              ……

n+2行:x1  y1  x2  y2  (分别为起点、终点坐标)

输出

输出s (即最少的拐弯次数)

样例输入

5 7

1 0 0 0 0 1 0

0 0 1 0 1 0 0

0 0 0 0 1 0 1

0 1 1 0 0 0 0

0 0 0 0 1 1 0

1 3 1 7

样例输出

5

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <algorithm>
using namespace std;
const int N=110;
int a[N][N];/*建矩阵,建两个更好写点*/
int n,m,x2,y2;
set<int>se; /*求的是最少转弯数,所以必须全列出来,所以用set存一下,*/
            /*直接输出第一个就行了,其实效率很低,建议用min */
void dfs(int x,int y,int turn,int dire){ /*turn是转弯数,dire是前一次的方向,避免来回走*/
    if(x==x2&&y==y2) se.insert(turn);/*存每种走法的转弯数*/
    else {
        if(y+1<=m&&a[x*2-1][2*y]==0&&!a[x*2-1][(y+1)*2-1]){
            a[x*2-1][(y+1)*2-1]=1;
            a[x*2-1][2*y]=1;
            if(dire==1||dire==0)/*起始位置或者转的方向相同转弯数不加*/
                dfs(x,y+1,turn,1);
            else/*方向变了,加1*/
                dfs(x,y+1,turn+1,1);
            a[x*2-1][(y+1)*2-1]=0;
            a[x*2-1][2*y]=0;
        }
        if(y-1>=1&&a[2*x-1][2*y-2]==0&&!a[x*2-1][(y-1)*2-1]){
            a[x*2-1][(y-1)*2-1]=1;
            a[2*x-1][2*y-2]=1;
            if(dire==2||dire==0)
                dfs(x,y-1,turn,2);
            else
                dfs(x,y-1,turn+1,2);
            a[x*2-1][(y-1)*2-1]=0;
            a[2*x-1][2*y-2]=0;
        }
        if(x+1<=n&&a[x*2][2*y-1]==0&&!a[(x+1)*2-1][y*2-1]){
            a[(x+1)*2-1][y*2-1]=1;
            a[x*2][2*y-1]=1;
            if(dire==3||dire==0)
                dfs(x+1,y,turn,3);
            else
                dfs(x+1,y,turn+1,3);
            a[(x+1)*2-1][y*2-1]=0;
            a[x*2][2*y-1]=0;
        }
        if(x-1>=1&&a[(x-1)*2][2*y-1]==0&&!a[(x-1)*2-1][y*2-1]){
            a[(x-1)*2-1][y*2-1]=1;
            a[(x-1)*2][2*y-1]=1;
            if(dire==4||dire==0)
                dfs(x-1,y,turn,4);
            else
                dfs(x-1,y,turn+1,4);
            a[(x-1)*2][2*y-1]=0;
            a[(x-1)*2-1][y*2-1]=0;
        }
    }
}
        
int main()
{
    scanf("%d%d",&n,&m);
    memset(a,0,sizeof(a));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            scanf("%d",&a[2*i-1][2*j-1]);
    int x1,y1;
    scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
    a[x1][y1]=1;/*初始位置标记保证不会再走*/
    dfs(x1,y1,0,0);/*初始转弯数和方向都是零*/
    printf("%d\n",(*se.begin()));
    return 0;
}

    原文作者:九宫格问题
    原文地址: https://blog.csdn.net/OttsWang/article/details/76648393
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞