DFS+BFS练习

A – Red and Black

 https://vjudge.net/contest/241948#problem/A

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.’ – a black tile 
‘#’ – a red tile 
‘@’ – a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

BFS代码实现:

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
int w,h;
char a[100][100];
int d[4][2]={0,1,0,-1,1,0,-1,0};
int vis[100][100];
struct node{
	int x,y;
};
void BFS(int sx,int sy)
{
	queue<node> q;
	node now,next;
	memset(vis,0,sizeof(vis));
	now.x=sx;
	now.y=sy;
	q.push(now);
	int ans=1;
	vis[sx][sy]=1;
	while(!q.empty())
	{

		now=q.front();
		q.pop();
	for(int i=0;i<4;i++)
	{
		next.x=now.x+d[i][0];
		next.y=now.y+d[i][1];
		if(next.x>=0&&next.x<h&&next.y>=0&&next.y<w&&a[next.x][next.y]=='.'&&vis[next.x][next.y]!=1)
		{
			ans++;
			q.push(next);
			vis[next.x][next.y]=1;
		}
	}
    }
    printf("%d\n",ans);
}
int main()
{
	while(~scanf("%d%d",&w,&h)&&(w||h))
	{
		int sx,sy;
		for(int i=0;i<h;i++)
		scanf("%s",&a[i]);
		for(int i=0;i<h;i++)
			for(int j=0;j<w;j++)
				if(a[i][j]=='@')	{
					sx=i;sy=j;break;
				} 
				BFS(sx,sy);
   }
	return 0;
}

DFS代码实现:

一直有问题,找了非常长时间的bug!!!,DFS里if的条件应该是’.’或者’@’,因为第一个总是从@开始的。要么就直接写成不等于’#’也成

#include <stdio.h>
#include <string.h>
using namespace std;
int w,h,ans;
char a[100][100];
int d[4][2]={0,1,0,-1,1,0,-1,0};
int vis[100][100];
void DFS(int sx,int sy){
    	if(sx>=0&&sx<h&&sy>=0&&sy<w&&(a[sx][sy]=='.'||a[sx][sy]=='@')&&vis[sx][sy]!=1)//错了n次,应该是点或‘@’,否则第一个就过不去 
    	{
        ans++;
        int fx,fy;
        for(int i=0;i<4;i++){
            vis[sx][sy] = 1;
            fx=sx+d[i][0];
            fy=sy+d[i][1];
            DFS(fx,fy);
        }
    }
}

int main()
{
	while(~scanf("%d%d",&w,&h)&&(w||h))
	{
		memset(vis,0,sizeof(vis));
		ans=0;
		int sx,sy;
		for(int i=0;i<h;i++)
		scanf("%s",a[i]);
		for(int i=0;i<h;i++)
			for(int j=0;j<w;j++)
				if(a[i][j]=='@')	{
				sx=i;sy=j;break;
				} 
				DFS(sx,sy);
				printf("%d\n",ans);
   }
	return 0;
}

 

    原文作者:DFS
    原文地址: https://blog.csdn.net/nanfengzhiwoxin/article/details/81335024
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞