UVA10004 Bicoloring【DFS】

In 1976 the “Four Color Map Theorem” was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.

  Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

    • no node will have an edge to itself.

    • the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.

    • the graph will be strongly connected. That is, there will be at least one path from any node to any other node.

Input

The input consists of several test cases. Each test case starts with a line containing the number n (1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number a (0 ≤ a < n).

  An input with n = 0 will mark the end of the input and is not to be processed.

Output

You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input

3

3

0 1

1 2

2 0

3

2

0 1

1 2

9

8

0 1

0 2

0 3

0 4

0 5

0 6

0 7

0 8

0

Sample Output

NOT BICOLORABLE.

BICOLORABLE.

BICOLORABLE.

 

 

问题链接UVA10004 Bicoloring

问题简述:(略)

问题分析

  这是一个典型的深度优先搜索问题。

程序说明

  节点规模不大,图就用邻接矩阵来表示。

  节点用两个颜色来图色,那就用0和1,程序15行实现了这个逻辑。

题记:(略)

参考链接:(略)

 

AC的C++语言程序如下:

/* UVA10004 Bicoloring */

#include <bits/stdc++.h>

using namespace std;

const int N = 200;
int n, l, g[N][N], vis[N];

bool dfs(int s)
{
    for (int i = 0; i < n; i++) {
        if (g[s][i]) {
            if (!vis[i]) {
                vis[i] = 1 - vis[s];
                if (!dfs(i))
                    return false;
            } else if (vis[i] == vis[s])
                return false;
        }
    }
    return true;
}

int main()
{
    while(~scanf("%d", &n) && n) {
        memset(g, 0, sizeof(g));
        memset(vis, 0, sizeof(vis));

        scanf("%d", &l);
        while(l--) {
            int source, target;
            scanf("%d%d", &source, &target);
            g[source][target] = g[target][source] = 1;
        }

        vis[0] = 1;
        printf("%s\n", dfs(0) ? "BICOLORABLE." : "NOT BICOLORABLE.");
    }

    return 0;
}

 

 

 

 

 

 

 

    原文作者:DFS
    原文地址: https://blog.csdn.net/tigerisland45/article/details/79857788
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞