求所有前缀-后缀字符串相等的长度(kmp算法中的nxet数组)

Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17086 Accepted: 8715

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father’s name and the mother’s name, to a new string S. 

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

思路:利用next数组求解

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int Max=400005;
char str[Max];
int l,next[Max],ans[Max];
void get_next()
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<l)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
		j=next[j];
	}
}
int main()
{
	while(~scanf("%s",str))
	{
		l=strlen(str);
		get_next();
		ans[0]=l;
	//	for(int i=0;i<=l;i++)
	//	printf("%d ",next[i]);
	//	printf("\n");
		int n=0,i=l;
		while(next[i]>0)
		{
			ans[++n]=next[i];   
			i=next[i];
		}
		for(i=n;i>=0;i--)
		printf("%d ",ans[i]);
		printf("\n");
	}
	return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/hz18790581821/article/details/52165996
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞