HDU:1686 Oulipo(KMP包含字符串(不是分割))

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11360    Accepted Submission(s): 4458

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

 

Output For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input

3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN  

Sample Output

1 3 0  

Source
华东区大学生程序设计邀请赛_热身赛  

Recommend

lcy   |   We have carefully selected several similar problems for you:  1358 3336 3746 2203 3068 

解题思路:给你一个字符串s2,一个字符串s1,问s1中包含了多少个s2(注意是包含不是分割,如上面的例子AZAZAZA 和AZA,如果是分割的话答案是2,如果是包含的话答案是3,包含的话注意匹配成功后k怎么处理,看代码)

代码如下:

#include <cstdio>
#include <cstring>
char s1[1000010];
char s2[10010];
int next[10010];
int ans,size1,size2;
void makenext()
{
	int k=0;
	memset(next,0,sizeof(next));
	for(int i=1;i<size2;i++)
	{
		while(k>0&&s2[k]!=s2[i])
		{
			k=next[k-1];
		}
		if(s2[k]==s2[i])
		{
			k++;
		}
		next[i]=k;
	}
}
void kmp()
{
	int k=0;
	for(int i=0;i<size1;i++)
	{
		while(k>0&&s2[k]!=s1[i])
		{
			k=next[k-1];
		}
		if(s2[k]==s1[i])
		{
			k++;
		}
		if(k==size2)
		{
			ans++;
			k=next[k-1];//注意这里,最后一个点当做不相等吧,然后就得滑动s2串了,符合题意的包含,不是分割 
		}
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s2);
		scanf("%s",s1);
		size1=strlen(s1);
		size2=strlen(s2);
		makenext();
		ans=0;
		kmp();
		printf("%d\n",ans);
	}
	return 0;
} 

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/zugofn/article/details/52225312
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞