F - Wormholes(Bellman_Ford)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

给你三个数n,m,w,分别表示有n个农场,m条路,w个黑洞,接下来m行分别有三个数s,e,val表示s到e有一条权值为val 的边,接下来的w行每行有三个数s,e,val表示s到e有一条权值为0-val的边,因为黑洞可以回到过去,所以其权值为负。现在问你给你这些点,求每组数据是否存在一条回路能使时间倒退。寻找一条负权边,因为负权边在松弛时可以无限松弛,所以只要判断是否存在一条可以无限松弛的负权边就可以了。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
struct node
{
   int u;
   int v;
   int step;
}e[121212121];
int n, m, w;
bool Bellman_Ford(int ans)
{
   int dis[1212121];
   memset(dis, INF, sizeof(dis));
   for(int i=1;i<=n;i++)
   {
      bool flag = false;
      for(int j=1;j<ans;j++)
      {
         if(dis[e[j].v]>dis[e[j].u] + e[j].step)
         {
           flag = true;
           dis[e[j].v] = dis[e[j].u] + e[j].step;
         }
      }
      if(flag==false)
      {
         break;
      }
   }
   for(int i=1;i<ans;i++)//寻找无限松弛的负权边
   {
      if(dis[e[i].v]>dis[e[i].u] + e[i].step)
      return true;//找到
   }
   return false;
}
int main()
{
   int T;
   scanf("%d", &T);
   while(T--)
   {
      scanf("%d %d %d", &n, &m, &w);
      int ans = 1;//记录边数
      for(int i=0;i<m;i++)
      {
      int a, b, c;
      scanf("%d %d %d", &a, &b, &c);//双向
        e[ans].u = a;
        e[ans].v = b;
        e[ans++].step = c;
        e[ans].u = b;
        e[ans].v = a;
        e[ans++].step = c;
      }
      for(int i=0;i<w;i++)//负权
      {
         int a, b, c;
         scanf("%d %d %d", &a, &b, &c);
         e[ans].u = a;
         e[ans].v = b;
         e[ans++].step = 0 - c;
      }
      if(Bellman_Ford(ans))
      cout<<"YES"<<endl;
      else
      cout<<"NO"<<endl;
   }
   return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/FEATHER2016/article/details/77917849
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞