E - Currency Exchange(Bellman_Ford)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input
The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

多组输入,n种货币 ,m个兑换点,ma是拥有的钱数,s是货币的种类,然后接下来有m行,每行六个数据, a货币,b货币,a->b 的C ,R, b->a的C ,R;询问是否可以通过这几种兑换,让ma 变多。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
struct node
{
   int v;//a货币
   int u;//b货币
   double R;
   double C;
}money[121212];
int n, m, s;
double ma;
bool Bellman_Ford()
{
   int E = m * 2;
   double  dis[121212];//第几种货币的钱数
   for(int i=0;i<=n;i++)
   {
      dis[i] = 0.0;
   }
   dis[s] = ma;//初始化
   while(dis[s]<=ma+1e-9)//当前数小的时候,继续
   {
   int flag = 0;
   for(int i=0;i<E;i++)
   {
     double temp = (dis[money[i].v] - money[i].C) * money[i].R;
     if(dis[money[i].u]+1e-9<temp)//更新
     {
        dis[money[i].u] = temp;
        flag = 1;
     }
   }
   if(flag==0)//无更新
   return (dis[s] - ma )> 0;
   }
   return true;
}
int main()
{
    while(~scanf("%d %d %d %lf", &n, &m, &s, &ma))
    {
        for(int i=0;i<m;i++)
        {
            int a, b;
            double fa, fb, ha, hb;
            scanf("%d %d %lf %lf %lf %lf", &a, &b, &fa, &fb, &ha, &hb);
            //a->b兑换
           money[i].v = a;
           money[i].u = b;
           money[i].R = fa;
           money[i].C = fb;
           //b->a兑换
           money[i+m].v = b;
           money[i+m].u = a;
           money[i+m].R = ha;
           money[i+m].C = hb;
        }
        if(Bellman_Ford())
        cout<<"YES"<<endl;
        else
        cout<<"NO"<<endl;
    }
   return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/FEATHER2016/article/details/77917486
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞