poj2240Arbitrage_spfa & bellman-Ford

poj2240Arbitrage:http://poj.org/problem?id=2240

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19216 Accepted: 8128

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题意,给你一些汇率,计算是否能套利….

思路:用spfa或bellman-Ford求正环……

spfa:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>

using namespace std;

#define INF 0x3f3f3f3f
const int MAXN = 100;
map<string,int>Map;
char str[100],str1[100];
int graph[MAXN][MAXN];
int n,m;
struct Node
{
    int v;
    double cost;
    Node(int _v=0,double _cost=0):v(_v),cost(_cost) {}
};
vector<Node>V[MAXN];
bool vis[MAXN];
double dis[MAXN];
bool spfa()
{
    memset(vis,false,sizeof(vis));
    memset(dis,0,sizeof(dis));
    queue<int>q;
    q.push(1);
    dis[1] = 1;
    vis[1] = true;
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = false;
        for(int i = 0; i < V[u].size(); i++)
        {
            int v = V[u][i].v;
            double cost = V[u][i].cost;
            if(dis[v] < dis[u] * cost)
            {
                dis[v] = dis[u] * cost;
                if(dis[1] > 1)return true;
                if(!vis[v])
                {
                    vis[v] = true;
                    q.push(v);
                }
            }
        }
    }
    return false;
}
int main()
{
    int ca = 1;
    while(~scanf("%d",&n) && n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%s",str);
            if(!Map[str])Map[str] = i;
        }
        scanf("%d",&m);
        double cost;
        for(int i = 0; i < m; i++)
        {
            scanf("%s%lf%s",str,&cost,str1);
            V[Map[str]].push_back(Node(Map[str1],cost));
        }
        printf("Case %d: ",ca++);
        if(spfa())printf("Yes\n");
        else printf("No\n");
        Map.clear();
        for(int i = 0; i <= n; i++)
            V[i].clear();
    }
    return 0;
}

bellman-ford的就不写了,直接套用模板就可以.

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/hahaAll/article/details/50845609
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞