Time Limit: 2000MS | Memory Limit: 65536KB | 64bit IO Format: %I64d & %I64u |
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer,
F.
F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively:
N,
M, and
W
Lines 2..
M+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: a bidirectional path between
S and
E that requires
T seconds to traverse. Two fields might be connected by more than one path.
Lines
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: A one way path from
S to
E that also moves the traveler back
T seconds.
Output
Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
#include<iostream>
#include<string.h>
#include<queue>
#include<stdio.h>
using namespace std;
const int INF=505;
int inq[INF];
int cnt[INF];
int low[INF];
int head[INF];
int n,m,c;
struct Edge
{
int next_edge,v,t;
} edge[INF*INF];
bool spfa(int arc)
{
queue<int>q;
q.push(arc);
cnt[arc]++;
memset(inq,0,sizeof(inq));
memset(cnt,0,sizeof(cnt));
memset(low,0x1f,sizeof(low));
low[arc]=0;
while(!q.empty())
{
int x=q.front();
q.pop();
inq[x]=0;
for(int e=head[x]; e!=-1; e=edge[e].next_edge)
{
if(low[edge[e].v]>low[x]+edge[e].t)
{
low[edge[e].v]=edge[e].t+low[x];
if(!inq[edge[e].v])
{
inq[edge[e].v]=1;
q.push(edge[e].v);
if(++cnt[edge[e].v]>n)
return 1;
}
}
}
}
return 0;
}
int main()
{
int t;
int x,y,z;
cin>>t;
while(t--)
{
memset(head,-1,sizeof(head));
cin>>n>>m>>c;
for(int i=0; i<m; i++)
{
cin>>x>>y>>z;
edge[i].next_edge=head[x];
edge[i].v=y;
edge[i].t=z;
head[x]=i;
edge[i+m].next_edge=head[y];
edge[i+m].v=x;
edge[i+m].t=z;
head[y]=i+m;
}
for(int i=0; i<c; i++)
{
cin>>x>>y>>z;
edge[i+2*m].next_edge=head[x];
edge[i+2*m].v=y;
edge[i+2*m].t=-z;
head[x]=i+2*m;
}
printf("%s\n",spfa(1)?"YES":"NO");
}
return 0;
}