poj 3259 bellman-ford算法 判断是否存在负权回路

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 41838 Accepted: 15364

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, 
F
F farm descriptions follow. 

Line 1 of each farm: Three space-separated integers respectively: 
N
M, and 
W 

Lines 2..
M+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: a bidirectional path between 
S and 
E that requires 
T seconds to traverse. Two fields might be connected by more than one path. 

Lines 
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: A one way path from 
S to 
E that also moves the traveler back 
T seconds.

Output

Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold

题目大意:虫洞问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b花费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到你从此点出发的从前,传说中的月光宝盒~ 看看至尊宝能否救下白骨精~~醉了~

解题思路:其实给出了坐标,这个时候就可以构成一张图,然后将回到从前理解为是否会出现负权环,用bellman-ford就可以解出了

bellman-ford的模版~


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;

#define INF 0x3f3f3f3f
#define N 1100
int n,m,w,tol;
struct node
{
    int s,e,t;
}p[5100];

int bellman()
{
    int i,j,dis[N];
    for(i=1;i<=n;i++)
    {
        dis[i]=(i==1)?0:INF;
    }

    for(i=0;i<=n-1;i++)
    {
        int f=0;
        for(j=0;j<tol;j++)
        {
            if(dis[p[j].e]>dis[p[j].s]+p[j].t)
            {
                dis[p[j].e]=dis[p[j].s]+p[j].t;
                f=1;
            }
        }
        if(f==0)
           break;
    }

    for(i=0;i<tol;i++)
    {
        if(dis[p[i].e]>dis[p[i].s]+p[i].t)
            return 1;
    }
    return 0;
}

int main()
{
    int T,a,b,c,i;
    scanf("%d",&T);
    while(T--)
    {
        tol=0;
        scanf("%d%d%d",&n,&m,&w);
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            p[tol].s=a;
            p[tol].e=b;
            p[tol].t=c;
            tol++;
            p[tol].s=b;
            p[tol].e=a;
            p[tol].t=c;
            tol++;
        }
        for(i=1;i<=w;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            p[tol].s=a;
            p[tol].e=b;
            p[tol].t=-c;
            tol++;
        }
        if(bellman())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/qq_33406883/article/details/51548153
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞