Arbitrage--(Bellman—Ford)

Arbitrage

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 48   Accepted Submission(s) : 18

Problem Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

 

Input The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. <br>Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.  

Output For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.  

Sample Input

3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0  

Sample Output

Case 1: Yes Case 2: No

Bellman—Ford判断是否有正权回路

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
#define inf 1000000
struct edge{
    int s,e; double v;
}p[905];
map<string,int>a;
double dis[32];
int main()
{
    int n,m,i,j,k,cas=0;
    while(scanf("%d",&n)&&n)
    {
        a.clear();
        string s1,s2;
        for(i=1;i<=n;i++)
        {
            cin>>s1;
            a[s1]=i;
        }
        double rate;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            cin>>s1;
            cin>>rate;
            cin>>s2;
            //cout<<a[s1]<<"  "<<a[s2]<<endl;
            p[i].s=a[s1];
            p[i].e=a[s2];
            p[i].v=rate;
        }
        bool flag;
        for(j=1;j<=n;j++)
                dis[j]=0;
        dis[1]=1;
        for(j=1;j<=n;j++)
        {
            flag=false;
            for(k=1;k<=m;k++)
            {
                if(dis[p[k].e]<p[k].v*dis[p[k].s])
                    {dis[p[k].e]=p[k].v*dis[p[k].s];flag=true;}
            }
            if(!flag) break;
        }
        flag=false;
        for(k=1;k<=m;k++)
        {
            if(dis[p[k].e]<p[k].v*dis[p[k].s])
                {flag=true; break;}
        }
        printf("Case %d: ",++cas);
        if(flag) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/sdau20163942/article/details/76982696
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞