POJ1860--Currency Exchange(最短路Bellman_Ford)

 Currency Exchange
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit 
Status Appoint description:  System Crawler  (2014-08-16)

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R 
AB, C 
AB, R 
BA and C 
BA – exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 
3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 
-2<=rate<=10 
2, 0<=commission<=10 
2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 
4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意有点不好理解,写一下意思(同学翻译)

     题意:有N种货币,货币之间通过汇率进行兑换,一个人持有一种货币,并且拥有一定数目的金额,问是否能通过货币之间的相互兑换实现他手中的货币的金额数增加,如果增加输出“YES” 反之输出“NO”。另外,货币之间的兑换是需要手续费的。例如,如果你想把100美元兑换成俄罗斯卢布,其中的汇率是29.75,而佣金是0.39,你会得到(100 – 0.39)*29.75=2963.3975俄罗斯卢布。明白这些就很好做了。
      第一行输入的数据:N种货币,M组数据,所持有的货币类别,所持有的货币的金额,
      第二行至第M+1行输入的数据:可以兑换的两种货币的种类x,y,后面的四个数分别代表把x兑换成y的汇率以及需要的手续费。和把y兑换成x的汇率以及所需要的手续费。
       可以看成是一个最短路问题:
贝尔曼福特算法代码:
《POJ1860--Currency Exchange(最短路Bellman_Ford)》

#include<stdio.h>
#include<string.h>
#define inf 1<<28
#define MAXN 1000000

double dis[MAXN];
int n, m, cnt, s;
double V;

struct node{
    int u, v;
    double rate, com;
}edge[MAXN];

void add(int uu, int vv, double rt, double cm)
{
	edge[cnt].u = uu;
	edge[cnt].v = vv;
	edge[cnt].rate = rt;
	edge[cnt++].com = cm;
}

bool Bellman_Ford()
{

	for(int i=0; i<=n; i++)
		dis[i] = 0;
	dis[s] = V;

	for(int i=0; i<n; i++)
	{
		bool flag = false;
		for(int j=0; j<cnt; j++)
		{
			if(dis[edge[j].v ] < (dis[edge[j].u]-edge[j].com)*edge[j].rate ){
				dis[edge[j].v] = (dis[edge[j].u] -edge[j].com )*edge[j].rate;
			    flag = true;
			}
			if( (dis[ edge[j].v] > V && edge[j].v == s)  )//这个优化更强,只要走一条回路,自己的钱增加就可以输出YES
				return true;
		}
		if(!flag) break;//优化
	}

	for(int j=0; j<cnt; j++)
	{
		if(dis[edge[j].v] < (dis[edge[j].u]-edge[j].com	)*edge[j].rate ){
			dis[edge[j].v] = (dis[edge[j].u]-edge[j].com)*edge[j].rate;

		 return true;//还可以松弛,说明存在正权回路
		}
	}
	return false;
}

int main()
{
	int uu, vv;
	double  rt_1, cm_1, rt_2, cm_2;
	while(~scanf("%d%d%d%lf", &n, &m, &s, &V))
	{
		cnt = 0;
		for(int i=0; i<m; i++)
		{
			scanf("%d%d%lf%lf%lf%lf", &uu, &vv, &rt_1, &cm_1, &rt_2, &cm_2);
			add(uu, vv, rt_1, cm_1);
			add(vv, uu, rt_2, cm_2);
		}

		if(Bellman_Ford())
			printf("YES\n");
		else
			printf("NO\n");

	}
	return 0;
}

       题意:有N种货币,货币之间通过汇率进行兑换,一个人持有一种货币,并且拥有一定数目的金额,问是否能通过货币之间的相互兑换实现他手中的货币的金额数增加,如果增加输出“YES” 反之输出“NO”。另外,货币之间的兑换是需要手续费的。例如,如果你想把100美元兑换成俄罗斯卢布,其中的汇率是29.75,而佣金是0.39,你会得到(100 – 0.39)*29.75=2963.3975俄罗斯卢布。明白这些就很好做了。
      第一行输入的数据:N种货币,M组数据,所持有的货币类别,所持有的货币的金额,
      第二行至第M+1行输入的数据:可以兑换的两种货币的种类x,y,后面的四个数分别代表把x兑换成y的汇率以及需要的手续费。和把y兑换成x的汇率以及所需要的手续费。
       可以看成是一个最短路问题:
贝尔曼福特算法代码:

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/u013492736/article/details/40431431
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞