While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input Line 1: A single integer,
F.
F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively:
N,
M, and
W
Lines 2..
M+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: a bidirectional path between
S and
E that requires
T seconds to traverse. Two fields might be connected by more than one path.
Lines
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: A one way path from
S to
E that also moves the traveler back
T seconds. Output Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes). Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:给出t表示t组测试数据。每组测试输出第一行给出n,m,w表示n个顶点,m条正权边,w条负权边,注意正权边是双向边,负权边是单向边。问图中是否存在负权回路
解题思路:判断是否存在负权回路模板题。回想所学过的(并不会)求解最短路的算法:Floyd,Dijkstra,Bellman-Ford以及SPFA。Dijkstra不能解决负权。
首先想到的是Bellman-Ford判断是否存在负权回路:
AC代码:
//Bellman-Ford
#include<stdio.h>
#define INF 0x3f3f3f3f
int dis[510],n,m,w;
struct edge
{
int s,e,t;
} e[2710];
void bellman()
{
int check;
for(int k=1;k<=n-1;k++)
{
check=0;
for(int i=1;i<=m;i++)//双向路
{
if(dis[e[i].s]+e[i].t<dis[e[i].e])
{
dis[e[i].e]=dis[e[i].s]+e[i].t;
check=1;
}
if(dis[e[i].e]+e[i].t<dis[e[i].s])
{
dis[e[i].s]=dis[e[i].e]+e[i].t;
check=1;
}
}
for(int i=m+1;i<=m+w;i++)//单向路
{
if(dis[e[i].s]+e[i].t<dis[e[i].e])
{
dis[e[i].e]=dis[e[i].s]+e[i].t;
check=1;
}
}
if(check==0) break;//本轮没有松弛表示整张图松弛完毕提前结束循环
}
int flag=0;
for(int i=1;i<=m+w;i++)//判断是否存在负权回路
{
if(dis[e[i].s]+e[i].t<dis[e[i].e])
{
flag=1;
break;
}
}
if(flag) printf("YES\n");
else printf("NO\n");
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&m,&w);
for(int i=1;i<=n;i++)
{
dis[i]=INF;
}
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
}
for(int i=m+1;i<=m+w;i++)
{
scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
e[i].t=-e[i].t;//转换为负数表示负权
}
bellman();
}
return 0;
}
一般情况下AC了就到此结束了(我说的是我),然而还可以思考下其他的方法。
以下来自hao817374童鞋:
Floyd 原理是一出现mp[i][i]<0就表示找到了负权回路
AC代码:
//Floyd
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int map[505][505],n,m,k;
int floyd()
{
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(map[i][j]>map[i][k]+map[k][j]) map[i][j]=map[i][k]+map[k][j];
}
if(map[i][i]<0) return 1;
}
}
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&m,&k);
memset(map,0x3f3f3f3f,sizeof(map));
for(int i=1;i<=n;i++)map[i][i]=0;
int a,b,c;
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
if(c<map[a][b])map[a][b]=map[b][a]=c;
}
for(int i=1;i<=k;i++)
{
scanf("%d%d%d",&a,&b,&c);
map[a][b]=-c;
}
int f=floyd();
if(!f)printf("NO\n");
else printf("YES\n");
}
return 0;
}
SPFA 原理是每个顶点最多扩展n-1次,如果超过n-1次必然存在负权回路
AC代码:
//spfa
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
using namespace std;
#define INF 0x3f3f3f3f
int n, head[505], dist[505];
int tot, ans[505], book[505];
struct node
{
int v, cost;
int next;
} edge[5210];
int spfa()
{
memset(book,0,sizeof(book));
memset(ans,0,sizeof(ans));
memset(dist,INF,sizeof(dist));
dist[1] = 0;
book[1] = 1;
queue<int>Q;
Q.push(1);
ans[1]++;
while( !Q.empty() )
{
int u = Q.front();
Q.pop();
for( int k = head[u]; k != -1; k = edge[k].next )
{
int v = edge[k].v;
int cost = edge[k].cost;
if( dist[v] > dist[u] + cost )
{
dist[v] = dist[u] + cost;
if( !book[v] )
{
//printf("v============%d\n",v);
book[v] = 1;
ans[v]++;
Q.push(v);
if( ans[v] >= n )
{
//printf("v===%d\n",v);
return 1;
}
}
}
}
book[u] = 0;
}
return 0;
}
void addedge( int u, int v, int w )
{
edge[tot].v = v;
edge[tot].cost = w;
edge[tot].next = head[u];
head[u] = tot++;
}
int main()
{
int T;
scanf("%d",&T);
while( T-- )
{
memset(head,-1,sizeof(head));
int m, w, t1, t2, t3;
scanf("%d%d%d",&n,&m,&w);
tot = 0;
for( int i = 0; i < m; i++ )
{
scanf("%d%d%d",&t1,&t2,&t3);
addedge(t1,t2,t3);
addedge(t2,t1,t3);
}
for( int i = 0; i < w; i++ )
{
scanf("%d%d%d",&t1,&t2,&t3);
addedge(t1,t2,-t3);
}
if( spfa() )
printf("YES\n");
else
printf("NO\n");
}
return 0;
}