POJ 3259 - Wormholes ( Floyd || Bellman - Ford)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:

   农民有N块地,每块地看做一个节点,有m条普通的路(双向),连接着两个节点,从一端走到另一端需要w时间(权值),还有wh条特殊的单向路,也就是题意中的虫洞,虫洞也连接着两个节点,但虫洞是单向的,从起点走到终点需要w时间,但这个时间是负的,也就是题意中所说的时光倒流。

判断是否为负权回路,第一行为n,m,w; n为n个点m为m条正权且是双向的,w为w条负权是单向的;下面先是m行正权边,再是w行负权边判断能否构成负权回路。(就是给N组测试数据,给你N个点M条无向边,再给你W个虫洞(可以使时间倒流),问你能不能看到刚出发时的自己。)

思路:

     Floyd最短路计算,把虫洞的时间存为负值,判断松弛后的自己到自己时间如果<0,说明满足他的条件。

  如果用Floyd,判断到了自己到自己的距离小于0了就跳出,不用再判断了,要不会超时。

代码:

#include<stdio.h>
#include<string.h>
int inf=99999999;
int main()
{
	int t,flag,n,m,a,b,c,i,j,k,u,w;
	int map[505][505];
	scanf("%d",&t);
	while(t--)
	{
		flag=0;
		memset(map,0,sizeof(map));
		scanf("%d%d%d",&n,&m,&w);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=inf;
			 } 
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(c<map[a][b])
			{
				map[a][b]=c;
				map[b][a]=c;
			}
		}
		for(i=1;i<=w;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			map[a][b]=-c;
		}
		for(k=1;k<=n;k++)
		{
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
				{
					if(map[i][j]>map[i][k]+map[k][j])
						map[i][j]=map[i][k]+map[k][j];
				}
				if(map[i][i]<0)
					flag++;
			}
			if(flag)
				break;
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");			
	}
	return 0;
 } 

 

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/wan_ide/article/details/81227437
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞