hdu 1874(dijkstra算法求最短路入门题)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1874

畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29681    Accepted Submission(s): 10831

Problem Description 某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。  

Input 本题目包含多组数据,请处理到文件结束。

每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。

接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。

再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。  

Output 对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

 

Sample Input

3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2  

Sample Output

2 -1  

Author linle  

Source
2008浙大研究生复试热身赛(2)——全真模拟   思路:直接dijkstra算法即可,算法讲解参考:http://www.wutianqi.com/?p=1890

PS:要注意的地方(1)起始点和出发点相同的时候

                                 (2)同样一条边可能会输入多次,要选其长度最小的一条边

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
const int INF=99999999;
const int N=220;
using namespace std;
int n,m;
int map[N][N]; //城镇到城镇之间的距离
int dis[N];//出发点到终点之间的距离
int sx,ex;//代表起始点和终点

void dijkstra()
{
  bool vis[N];
  memset(vis,false,sizeof(vis));
  vis[sx]=true;
  for(int i=1;i<=n;i++)
    dis[i]=map[sx][i];

  for(int i=2;i<=n;i++)
     {
      int temp=INF,u=sx;
      for(int j=1;j<=n;j++)
       if(!vis[j]&&dis[j]<temp)
        {
          temp=dis[j];
          u=j;
        }
      vis[u]=true; // 让u这一点加入s集合
      for(int j=1;j<=n;j++)//更新并且维护dis[]集合
       {
        if(!vis[j]&&map[u][j]+dis[u]<dis[j])
            dis[j]=map[u][j]+dis[u];
       }

     }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
      int p,q,len;//代表起始端点编号,终点编号,和两点之间的距离
      for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
          {
             if(i!=j)
              {
               map[i][j]=INF;
               map[j][i]=INF;
              }
             else
              {
               map[i][j]=0;
               map[j][i]=0;
              }
          }
      while(m--)
      {
        scanf("%d%d%d",&p,&q,&len);
        p++,q++;
        if(len<map[p][q])
         {
          map[p][q]=len;//双向连通
          map[q][p]=len;
         }
      }
      scanf("%d%d",&sx,&ex);
      sx++,ex++;
      dijkstra();
      if(dis[ex]==INF)cout<<-1<<endl;
      else cout<<dis[ex]<<endl;
    }
    return 0;
}
    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/liusuangeng/article/details/39737787
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞