POJ 2387 Til the Cows Come Home(Dijkstra判重边)

Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31748 Accepted: 10757

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

USACO 2004 November

题目大意:

说的是,一只奶牛位于N号节点,输入N个节点和T对双向的边,求出由N到1的最短的距离,其实就是问的单源最短路问题,首先想到了Dijkstra算法。

解题思路:

直接水过去吧,但是有一点非常重要,我也是因为这点给WA了一次,那就是对于重边的判断了,如果在双向边中,我们当然要取的是那个最短的那一次了,,因为是求最短路径了。代码我写的很规范了,,也是很容易理解的。。

代码:

# include<cstdio>
# include<iostream>

using namespace std;

# define MAX 1000+4
# define inf 99999999

int n,t;
int edge[MAX][MAX];
int dis[MAX];
int book[MAX];
int u,v;

void init()
{
    for ( int i = 1;i <= n;i++ )
    {
        for ( int j = 1;j <= n;j++ )
        {
            if ( i==j )
            {
                edge[i][j] = 0;
            }
            else
            {
                edge[i][j] = inf;
            }
        }
    }
}

void input()
{
    for ( int i = 0;i < t;i++ )
    {
        int t1,t2,t3;
        cin>>t1>>t2>>t3;
        if ( t3 < edge[t1][t2] )
        {
            edge[t1][t2] = t3;
            edge[t2][t1] = t3;
        }
    }

}


void Dijkstra()
{
    for ( int i = 1;i <= n;i++ )
    {
        book[i] = 0;
        dis[i] = edge[n][i];
    }

    int _min;
    for ( int i = 1;i <= n-1;i++ )
    {
       _min = inf;
       for ( int j = 1;j <= n;j++ )
       {
           if ( book[j]==0&&dis[j] < _min )
           {
               _min = dis[j];
                  u = j;
           }
       }

       book[u] = 1;
       for ( v = 1;v <= n;v++ )
       {
           if ( book[v]==0&&dis[v] > dis[u]+edge[u][v] )
           {
               dis[v] = dis[u]+edge[u][v];
           }
       }

    }
}

int main(void)
{
    while ( cin>>t>>n )
    {
        init();
        input();
        Dijkstra();
        cout<<dis[1]<<endl;

    }


    return 0;
}
    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/wikioi_bai/article/details/43924799
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞