1007. Maximum Subsequence Sum (25) -- 动态规划

1007. Maximum Subsequence Sum (25)题目地址

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

#include <iostream> 
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <queue>

using namespace std;

#define N 10001

int n;
int a[N];

int pre[N]; // 以i结尾的最大和的起点
int sum[N]; // 以i结尾的最大和

int main()
{
    //freopen("in", "r", stdin);
    scanf("%d", &n);
    int i;
    int negativeCount = 0;
    for (i = 0; i < n; i++)
    {
        scanf("%d", &a[i]);
        if (a[i] < 0)
        {
            negativeCount++;
        }
    }

    if (negativeCount == n)
    {
        printf("0 %d %d\n", a[0], a[n - 1]);// 这里需要按要求输出
        return 0;
    }
    pre[0] = 0;
    sum[0] = a[0];
    int maxx = sum[0];
    int maxxIndex = 0;
    for (i = 0; i < n; i++)
    {
        if (sum[i - 1] > 0)
        {
            sum[i] = a[i] + sum[i - 1];
            pre[i] = pre[i - 1];
        }
        else{
            sum[i] = a[i];
            pre[i] = i;
        }
        if (sum[i] > maxx)
        {
            maxx = sum[i];
            maxxIndex = i;
        }
    }

    printf("%d %d %d", maxx, a[pre[maxxIndex]], a[maxxIndex]);//这里输出也是
    printf("\n");
    return 0;
}
主要是递归方程, 还要看清楚题目的输入输出
    原文作者:动态规划
    原文地址: https://blog.csdn.net/qq_26437925/article/details/47621173
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞