POJ 3687-Labeling Balls(逆序拓扑排序)

Labeling Balls

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11256 Accepted: 3230

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like “The ball labeled with a is lighter than the one labeled with b”.

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls’ weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on… If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

题意:有T组测试数据,每组测试数据第一行有两个数n,m。代表有n个球,接下来m行,每行有两个数a,b,代表a球比b球轻,让你从小到大输出球的重量,若是相同重量,按照字典序输出。

思路:这个和以前的拓扑排序略微不同,不是考虑入度为0的情况。因为假设n为4,4<1.则输出的列是2,3,4,1,而不是按照以前所说的 4,1,2,3.所以要考虑的是先把最重的放在后面,轻的在前面按照字典序输出就可以了。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <set>
using namespace std;
int map[210][210];
int out[210];
void topo(int n)
{
    int i;
    int cnt=n;
    int weight[210];
    priority_queue<int >q;//优先队列,按照从大到小排序。
    for(i=1;i<=n;i++){
        if(out[i]==0)
            q.push(i);
    }
    while(!q.empty()){
        int k=q.top();
        q.pop();
        weight[k]=cnt--;
        for(i=1;i<=n;i++){
            if(map[i][k]){
                out[i]--;
                if(out[i]==0)
                    q.push(i);
            }
        }
    }
    if(cnt>0)
        printf("-1\n");
    else{
        for(i=1;i<n;i++)
            printf("%d ",weight[i]);
        printf("%d\n",weight[i]);
    }
}
int main()
{
    int T,n,m,i,j;
    int a,b;
    scanf("%d",&T);
    while(T--){
        scanf("%d %d",&n,&m);
        memset(out,0,sizeof(out));
        memset(map,0,sizeof(map));
        while(m--){
            scanf("%d %d",&a,&b);
            if(map[a][b]==0){
                map[a][b]=1;
                out[a]++;
            }
        }
        topo(n);
    }
    return 0;
}
    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/u013486414/article/details/42616073
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞