POJ 2367:Genealogical tree(拓扑排序)

Genealogical tree

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 2738
Accepted: 1838
Special Judge

Description

The system of Martians’ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there’s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member’s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers’ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

题意:大意就是给你一个N个点的图,并且给你图中的有向边,要你输出一个可行的点拓扑序列即可.输入格式为,第一行点数N,以下接着有N行,每行以0结尾.第i行包含了以i点为起点的有向边所指的所有节点.

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
#include<vector>

using namespace std;

const int M = 100 + 50;
int n;
int in[M];
int out[M];
vector<int> map[M];

void toposort()
{
    queue<int>Q;
    for(int i=1; i<=n; i++)
        if( !in[i] )  //未出现的数
        Q.push( i );
    int cnt = 0;
    while( !Q.empty() )
    {
        int u = Q.front();
        //printf( "%d\n", u );
        Q.pop();
        out[ ++cnt ] = u;  //用数组存下结果
        for(int i=0; i<map[u].size(); i++) //每行记录的数字分别入队
        {
            int m = map[u][i];
            if( --in[m] == 0 )   //如果这个数出现多次则先不如队
                Q.push( m );
        }
    }
}

int main()
{
    while( scanf( "%d", &n )==1 && n )
    {
        for(int i=1; i<=n; i++)
        {
            map[i].clear(); //vector数组的初始化
            in[i] = 0;
            int m;
            for( ; ; )
            {
                scanf( "%d", &m );
                if( m==0 )
                    break;
                map[i].push_back( m );
                in[m]++;
            }
        }
        toposort();
        for(int i=1; i<=n; i++)
        {
            if( i<n )
                printf( "%d ", out[i] );
            else
                printf( "%d\n", out[i] );
        }
    }

    return 0;
}




    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/u013487051/article/details/37913587
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞