数据结构实验之图论四:迷宫探索
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
有一个地下迷宫,它的通道都是直的,而通道所有交叉点(包括通道的端点)上都有一盏灯和一个开关;请问如何从某个起点开始在迷宫中点亮所有的灯并回到起点?
Input
连续T组数据输入,每组数据第一行给出三个正整数,分别表示地下迷宫的结点数N(1 < N <= 1000)、边数M(M <= 3000)和起始结点编号S,随后M行对应M条边,每行给出一对正整数,表示一条边相关联的两个顶点的编号。
Output
若可以点亮所有结点的灯,则输出从S开始并以S结束的序列,序列中相邻的顶点一定有边,否则只输出部分点亮的灯的结点序列,最后输出0,表示此迷宫不是连通图。
访问顶点时约定以编号小的结点优先的次序访问,点亮所有可以点亮的灯后,以原路返回的方式回到起点。
Sample Input
1
6 8 1
1 2
2 3
3 4
4 5
5 6
6 4
3 6
1 5
Sample Output
1 2 3 4 5 6 5 4 3 2 1
Hint
Source
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int a[1001][1001],book[1001],b[1001];
int p,n;
void dfs(int cur)
{
b[p++]=cur;
for(int i=1;i<=n;i++)
{
if(a[cur][i]==1&&book[i]==0)
{
book[i]=1;
dfs(i);
b[p++]=cur;//要用上一层循环的值,不能是i,如果是i的话,那就是本层的i了
//用cur代表是上一层的
}
}
}
int main()
{
int t,m,s;
scanf("%d",&t);
while(t--)
{
p=0;
scanf("%d%d%d",&n,&m,&s);
memset(a,0,sizeof(a));
memset(book,0,sizeof(book));
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
a[x][y]=1;
a[y][x]=1;
}
book[s]=1;
dfs(s);
for(int i=0;i<p;i++)
{
if(i==0)printf("%d",b[i]);
else printf(" %d",b[i]);
}
if(p!=2*n-1)printf(" 0\n");
else printf("\n");//注意题意的说明;
}
return 0;
}