数据结构实验之图论二:基于邻接表的广度优先搜索遍历
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
给定一个无向连通图,顶点编号从0到n-1,用广度优先搜索(BFS)遍历,输出从某个顶点出发的遍历序列。(同一个结点的同层邻接点,节点编号小的优先遍历)
输入
输入第一行为整数n(0< n <100),表示数据的组数。
对于每组数据,第一行是三个整数k,m,t(0<k<100,0<m<(k-1)*k/2,0< t<k),表示有m条边,k个顶点,t为遍历的起始顶点。
下面的m行,每行是空格隔开的两个整数u,v,表示一条连接u,v顶点的无向边。
输出
输出有n行,对应n组输出,每行为用空格隔开的k个整数,对应一组数据,表示BFS的遍历结果。
示例输入
1
6 7 0
0 3
0 4
1 4
1 5
2 3
2 4
3 5
示例输出
0 3 4 2 5 1
提示
用邻接表存储。
# include <stdio.h>
# include <stdlib.h>
# include <memory.h>
typedef struct node
{
int vertex;
struct node*next;
} Node;
Node *head[100];//开辟顶点的指针数组
int visited[100];//用来记录顶点是否访问过,访问过置为1,没访问过为0
int queue[100];
int front,rear;
void BFS(int t);
void add_to_head(Node*head,int v);
int main()
{
Node*p;
int n,k,m,t,i;
int v1,v2;
scanf("%d",&n);
for(i=0;i<100;i++)
{
head[i] = (Node*)malloc(sizeof(Node));
// head[i]->next = NULL;
}
while(n--)
{
memset(visited,0,sizeof(visited));
scanf("%d%d%d",&k,&m,&t);
for(i=0;i<k;i++)
{
head[i]->next = NULL;
}
while(m--)
{
scanf("%d%d",&v1,&v2);
add_to_head(head[v1],v2);
add_to_head(head[v2],v1);
}
/* 检测建的邻接表
for(i=0;i<k;i++)
{
p = head[i]->next;
printf("顶点%d::",i);
while(p)
{
printf("%d ",p->vertex);
p = p->next;
}
printf("%\n");
}
*/
BFS(t);
}
return 0;
}
void BFS(int t)
{
int peak ;
Node*p;
front = rear = 0;
queue[rear++] = t;
visited[t] = 1;
printf("%d",t);
while(front < rear)
{
peak = queue[front++];
p = head[peak]->next;
while(p)
{
if(!visited[p->vertex])
{
printf(" %d",p->vertex);
visited[p->vertex] = 1;
queue[rear++] = p->vertex;
}
p = p->next;
}
}
}
/*建立有序链表*/
void add_to_head(Node*head,int v)
{
Node*p,*q,*r;
p = (Node*)malloc(sizeof(Node));
p->vertex = v;
p->next = NULL;
q = head;
r = head->next;
while(r && r->vertex < v)
{
q = r;
r = r->next;
}
q->next = p;
p->next = r;
}