hdu1075 map

http://acm.hdu.edu.cn/showproblem.php?pid=1075

题意 翻译文本

Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?


Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.


Output
In this problem, you have to output the translation of the history book.


Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END


Sample Output
hello, i'm from mars.
i like earth!
#include <iostream>
#include <map>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

map<string,string>m;

int main()
{
    string s1,s2;
    cin>>s1;
    while(cin>>s1)
    {
        if(s1=="END")
        break;
        cin>>s2;
        m[s2]=s1;
    }
    char c;
    string ss="";
    cin>>s1;
    c=getchar();
    while(1)
    {
        while(1)
        {
            scanf("%c",&c);
            if(!isalpha(c))break;
            ss+=c;
        }
        if(ss=="END")break;
        if(m.find(ss)!=m.end())
        cout<<m[ss];
        else
        cout<<ss;
        ss="";
        cout<<c;
    }
    return 0;
}
    原文作者:B树
    原文地址: https://blog.csdn.net/aonaigayiximasi/article/details/52765995
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞