2503:Babelfish(Trie树)

描述
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
输入
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
输出
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.
样例输入
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
样例输出
cat
eh
loops
提示
Huge input and output,scanf and printf are recommended.
来源
Waterloo local 2001.09.22

#include <bits/stdc++.h>
using namespace std;
struct TrieTree
{
    TrieTree *next[26];
    char *english;
    TrieTree(){
        for(int i=0;i<26;++i){
            next[i]=NULL;
        }
        english=NULL;
    }
};
void insert(TrieTree *p,char dialect[],char english[])
{
    int i=0;
    while(dialect[i]){
        int k=dialect[i++]-'a';
        if(p->next[k]==NULL){
            p->next[k]=new TrieTree();
        }
        p=p->next[k];
    }
    p->english=new char[16];
    strcpy(p->english,english);
}
void search(TrieTree *p,char dialect[])
{
    int i=0;
    while(dialect[i]){
        int k=dialect[i++]-'a';
        if(p->next[k]) p=p->next[k];
        else {
            printf("eh\n");
            return;
        }
    }
    if(p->english){
        printf("%s\n",p->english);
    }else{
        printf("eh\n");
    }
}
int main()
{
    TrieTree r;
    char lines[32],dialect[16],english[16];
    while(gets(lines)&&lines[0]!='\0'){
        sscanf(lines,"%s %s",english,dialect);
        insert(&r,dialect,english);
    }
    while(~scanf("%s",dialect)){
        search(&r,dialect);
    }
    return 0;
}
    原文作者:Trie树
    原文地址: https://blog.csdn.net/gl486546/article/details/79829727
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞