Shortest Prefixes
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 20904 | Accepted: 9001 |
Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.
An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate cart carburetor caramel caribou carbonic cartilage carbon carriage carton car carbonate
Sample Output
carbohydrate carboh cart cart carburetor carbu caramel cara caribou cari carbonic carboni cartilage carti carbon carbon carriage carr carton carto car car carbonate carbona
Source
我们怎么做这个题目呢? 我们手动建棵树
发现答案不过就是树前缀为1的前面所有点加上当前这个前缀为1的答案
那么我们建树所有前缀都加一 输出即可
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 2000024;
int tree[MAX_N][30];
int cnt[MAX_N];
int tot;
void Insert(char *str){
int len=strlen(str);
int root = 0;
for(int i = 0;i<len;++i){
int id = str[i]-'a';
if(!tree[root][id]) tree[root][id] = ++tot;
root = tree[root][id];
cnt[root]++;
}
}
string Find(char *str){
int len = strlen(str);
string ans;
ans ="";
int root = 0;
for(int i = 0;i<len;++i){
int id = str[i]-'a';
root = tree[root][id];
if(cnt[root]!=1) ans+=str[i];
if(cnt[root]==1){
ans+=str[i];
break;
}
}
return ans;
}
char str[10000][25];
int main(){
int num = 0;
while(scanf("%s",str[num])!=EOF){
Insert(str[num]);
num++;
}
for(int i=0;i<num;i++){
string ans;
ans = Find(str[i]);
//dbg(ans);
printf("%s ",str[i]);
printf("%s\n",ans.c_str());
}
return 0;
}