HDU--1075(stl或trie树)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1075

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him? 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(‘ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters. 

Output

In this problem, you have to output the translation of the history book. 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

        
 

思路:

用到了stl的find函数,以及映照关系

做法一:

#include <iostream>
#include <stdio.h>
#include <map>
#include <string.h>
#include <string>
using namespace std;

map<string,string>ma;
char s[3010];
string a,b;

int main()
{
    cin >> a;
    while(cin >> a)
    {
        if(a == "END")
            break;
        else{
            cin >> b;
            ma[b] = a;
        }
    }
    cin >> a;
    getchar();
    while(1)
    {
        gets(s);
        if(!strcmp(s,"END"))
            break;
        int len = strlen(s);
        a = "";
        for(int i = 0;i < len;i ++)
        {
            if(islower(s[i]))
                a += s[i];
            else
            {
                if(ma.find(a) != ma.end())
                {
                    cout << ma[a];
                }
                else cout << a;
                a = "";
                cout << s[i];
            }
        }
        cout << endl;
    }
    return 0;
}

 

    原文作者:Trie树
    原文地址: https://blog.csdn.net/guagua_de_xiaohai/article/details/83422329
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞