HDU 1011 Starship Troopers(树形DP)

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4118    Accepted Submission(s): 1076

Problem Description You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern’s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.  

 

Input The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers — the amount of bugs inside and the possibility of containing a brain, respectively. The next N – 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1’s.  

 

Output For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.  

 

Sample Input 5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1  

 

Sample Output 50 7  

 

Author XU, Chuan  

 

Source
ZJCPC2004         树形DP 定义dp[i][j]默示根结点为i时,用掉j个士兵获得的最大possible。

dp[i][j] = max(dp[i][j], dp[i][j-k] + dp[son[i]][k]);

递归的求出dp[son[i]][k]的值。最后成果就是dp[1][m];

 

 

题目大意是有n个房间组成一棵树,你有m个士兵,从1号房间开始让士兵向相邻的房间出发,每个房间里有一个代价,代价是值/20个士兵,

同时有一个价值,问你花费这m个士兵可以得到的最大价值是多少,

 

#include<stdio.h>
#include<iostream>
using namespace std;
const int MAXN=110;
int N,M;
struct Node
{
int number,p;
};
Node node[MAXN];//记录结点
int dp[MAXN][MAXN];//DP,dp[i][j]表示跟结点为i时,用掉j个士兵获得的最大值
int adj[MAXN][MAXN];//存树
bool vis[MAXN];//访问标记

void dfs(int root)//DFS
{
vis[root]=true;//已经访问
int num=(node[root].number+19)/20;//获得该结点需要的士兵数目
for(int i=num;i<=M;i++) dp[root][i]=node[root].p;
for(int i=1;i<=adj[root][0];i++)
{
int u=adj[root][i];
if(vis[u]) continue;
dfs(u);
for(int j=M;j>=num;j--)
{
for(int k=1;j+k<=M;k++)
{
if(dp[u][k])
dp[root][j+k]=max(dp[root][j+k],dp[root][j]+dp[u][k]);
}
}
}
}
int main()
{
int b,e;
while(scanf("%d%d",&N,&M))
{
if(N==-1&&M==-1) break;
memset(vis,false,sizeof(vis));
memset(dp,0,sizeof(dp));
memset(adj,0,sizeof(adj));
for(int i=1;i<=N;i++)
scanf("%d%d",&node[i].number,&node[i].p);
for(int i=1;i<N;i++)//存图
{
scanf("%d%d",&b,&e);
adj[b][0]++;
adj[b][adj[b][0]]=e;
adj[e][0]++;
adj[e][adj[e][0]]=b;
}
if(M==0)//这个必需要,有代价为0的房间,M=0则无法获得
printf("0\n");
else
{
dfs(1);
printf("%d\n",dp[1][M]);
}

}
return 0;
}

 

 

HDU 第235题了,纪念下。

离500题的目标越来越近了~~~~~~

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/03/14/2396449.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞