HDU 5573 Binary Tree 构造

Binary Tree

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5573

Description

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100.

⋅ 1≤N≤109.

⋅ N≤2K≤260.

Output

For every test case, you should output “Case #x:” first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as ‘a b’, where a is node label of the node the frog visited, and b is either ‘+’ or ‘-‘ which means he increases / decreases his number by a.

It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input

2

5 3

10 4

Sample Output

Case #1:

1 +

3 –

7 +

Case #2:

1 +

3 +

6 –

12 +

Hint

题意

有一颗完全二叉树,第一个节点是1,他的左儿子就是i x 2,右儿子是i x 2+1

然后让你找到一个路径,使得通过加减恰好向下走k步之后,权值和为n

题解:

构造题

首先我们可以分析得到,所有答案都可以通过走 1,2,4,8,16…..来得到

为什么?因为n<=2^k.

如果是奇数,那么我们最后一步就选左儿子,否则选择右儿子

路径问题解决了,我们就差符号问题了

符号问题,我们就可以通过找规律来解决

比如 n的二进制为100101

那么我们k步的符号就可以是110010(1表示+,0表示-)

就第一个位置是1,其他位置都是0就好了

比如001,你可以通过4-2-1来构造出来,就是001->100

讲得比较玄乎,大家意会吧 T T

代码

#include<bits/stdc++.h>
using namespace std;

long long n,k;
int flag = 0;
int a[100];
int main()
{
    int t;scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        scanf("%lld%lld",&n,&k);
        flag = 0;
        memset(a,0,sizeof(a));
        if(n%2==0)
        {
            flag = 1;
            n = n-1;
        }
        int tmp = 0;
        for(int i=k-1;i>=0;i--)
        {
            a[i]=1-tmp;
            tmp=1;
            if((n>>i)&1)
                tmp=0;
        }
        printf("Case #%d:\n",cas);
        long long now = 1;
        for(int i=0;i<k-1;i++)
        {
            printf("%lld ",now);
            now = now*2;
            if(a[i])printf("+\n");
            else printf("-\n");

        }
        if(flag)printf("%lld ",now+1);
        else printf("%lld ",now);
        if(a[k-1])printf("+\n");
        else printf("-\n");

    }
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5059326.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞