HDU 1028 Ignatius and the Princess III (母函数,或者DP)

Ignatius and the Princess III

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:

  N=a[1]+a[2]+a[3]+…+a[m];

  a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

  4 = 4;

  4 = 3 + 1;

  4 = 2 + 2;

  4 = 2 + 1 + 1;

  4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3″ is the same in this problem. Now, you do it!”

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

Author

Ignatius.L     前面已经写了一篇用母函数做的:
http://www.cnblogs.com/kuangbin/archive/2011/07/30/2122192.html 母函数的意思就是把n 用1,2,3,4,5““`来表示的种数,构造母函数:(1+x+x^2+x^3+““`)*(1+x^2+x^4+““)*(1+x^3+x^6+““)““   其实发现不用母函数也可以做出来。 就是用递归也可以做,只不过递归的时候要DP的方法记录下来。 程序如下:

#include<stdio.h>
#include<string.h>
const int MAXN=130;
int dp[MAXN][MAXN];
//dp[i][j]表示 i 表示成最大的数不超过 j 的方法数
int calc(int n,int m)
{
    
    if(dp[n][m]!=-1) return dp[n][m];
    
    
    if(n<1||m<1) return dp[n][m]=0;
    if(n==1||m==1) return dp[n][m]=1;
    if(n<m) return dp[n][m]=calc(n,n);
    if(n==m) return dp[n][m]=calc(n,m-1)+1;
    return dp[n][m]=calc(n,m-1)+calc(n-m,m);
    
}     
int main()
{
    int n;
    memset(dp,-1,sizeof(dp));
    
    while(scanf("%d",&n)!=EOF)
      printf("%d\n",calc(n,n));
    return 0;
}    

这个的速度比母函数做要快。

而且想对好理解一点。

dp[n][m]的意思是把n,用最大不超过m的数来表示的方法数。

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/04/16/2452949.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞