hdu 5775 Bubble Sort 树状数组

Bubble Sort

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5775

Description

P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output

For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input

2
3
3 1 2
3
1 2 3

Sample Output

Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

Hint

题意

给你一个1-n的排列,然后让你跑冒牌排序,问你这个数曾经到过的最左边和最右边的位置的差是多少

题解:

考虑一个位置上的数字c在冒泡排序过程的变化情况。c会被其后面比c小的数字各交换一次,之后c就会只向前移动。数组从右向左扫,树状数组维护一下得到每个值右边有多少个比其小的值,加上原位置得到最右位置,最左位置为初始位置和最终位置的最小值。
时间复杂度\(O(n\ lg\ n)\)

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+7;
int cas = 0;
int a[maxn],b[maxn];
int ans[maxn];
int l[maxn],r[maxn];
int d[maxn];
int lowbit(int x){
    return x&(-x);
}
void update(int x){
    for(int i=x;i<maxn;i+=lowbit(i)){
        d[i]++;
    }
}
int get(int x){
    int ans = 0;
    for(int i=x;i;i-=lowbit(i))
        ans+=d[i];
    return ans;
}
void solve(){
    memset(d,0,sizeof(d));
    vector<pair<int,int> >V;
    int n;scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        V.push_back(make_pair(a[i],i));
    }
    sort(V.begin(),V.end());
    for(int i=0;i<V.size();i++){
        ans[i+1]=max(V[i].second,V[i].second+get(maxn-1)-get(V[i].second))-min(V[i].first,V[i].second);
        update(V[i].second);
    }
    printf("Case #%d:",++cas);
    for(int i=1;i<=n;i++){
        printf(" %d",ans[i]);
    }
    printf("\n");
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--)solve();
    return 0;
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5715883.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞