HDU 1034 Candy Sharing Game(水模拟)

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1685    Accepted Submission(s): 1045

Problem Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.  

 

Input The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.  

 

Output For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.  

 

Sample Input 6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0  

 

Sample Output 15 14 17 22 4 8
Hint The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.  

 

Source
Greater New York 2003       看懂题目意思。。。。很简单的模拟。。。。   注意先给别人,再从别人那获得,主要边界处理  

#include<stdio.h>
const int MAXN=1000;
int a[MAXN];
int main()
{
    int n;
    int i;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++) scanf("%d",&a[i]);
        int res=0;
        while(1)
        {
            for(i=1;i<n;i++)
              if(a[i-1]!=a[i]) break;
            if(i>=n) break;
            res++;
            int temp=a[n-1]/2;
            for(i=n-1;i>0;i--)
            {
                a[i]/=2;
                a[i]+=a[i-1]/2;
            }   
            a[0]/=2; 
            a[0]+=temp;
            for(i=0;i<n;i++)
             if(a[i]&1) a[i]++;
        }    
        printf("%d %d\n",res,a[0]);
    }    
    return 0;
}   

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/06/03/2532690.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞