HDU 4642 Fliping game (2013多校4 1011 简单博弈)

 

 

Fliping game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 46    Accepted Submission(s): 35

Problem Description Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x
1, y
1)-(n, m) (1 ≤ x
1≤n, 1≤y
1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x
1≤x≤n, y
1≤y≤m)). The only restriction is that the top-left corner (i.e. (x
1, y
1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here’s the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.  

 

Input The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.  

 

Output For each case, output the winner’s name, either Alice or Bob.  

 

Sample Input 2 2 2 1 1 1 1 3 3 0 0 0 0 0 0 0 0 0  

 

Sample Output Alice Bob  

 

Source
2013 Multi-University Training Contest 4  

 

Recommend zhuyuanchen520  

 

和翻硬币那个很类似。

简单的博弈,找规律发现只有最右下角的SG值为1,其余的都为0;

所以所有1的SG值异或的结果取决于最右下角的。

只有右下角为1,输出Alice,否则输出Bob

 

/*
 *  Author:kuangbin
 *  1011.cpp
 */

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <set>
#include <string>
#include <math.h>
using namespace std;

int main()
{
    //freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int T;
    int a;
    scanf("%d",&T);
    while(T--)
    {
        int sum = 0;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i = 1;i <= n;i++)
            for(int j = 1;j <= m;j++)
        {
            scanf("%d",&a);
        }
        if(a)printf("Alice\n");
        else printf("Bob\n");
    }
    return 0;
}

 

 

 

 

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/p/3230610.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞