POJ 2185 Milking Grid(KMP)

Milking Grid

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 4738 Accepted: 1978

Description

Every morning when they are milked, the Farmer John’s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

Input

* Line 1: Two space-separated integers: R and C 

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow’s breed. Each of the R input lines has C characters with no space or other intervening character. 

Output

* Line 1: The area of the smallest unit from which the grid is formed 

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern ‘AB’.

Source

USACO 2003 Fall           做两次KMP   行和列分别是len-next[len];   最后两个结果相乘就可以了    

//============================================================================
// Name        : POJ.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <string>
using namespace std;
char str[10010][100];
int R,C;
bool same1(int i,int j)//第i行和第j行相等
{
    for(int k=0;k<C;k++)
        if(str[i][k]!=str[j][k])
            return false;
    return true;
}
bool same2(int i,int j)//第i列和第j列相等
{
    for(int k=0;k<R;k++)
        if(str[k][i]!=str[k][j])
            return false;
    return true;
}
const int MAXN=10010;
int next[MAXN];
int main()
{
    while(scanf("%d%d",&R,&C)==2)
    {
        for(int i=0;i<R;i++)scanf("%s",str[i]);
        int i,j;
        j=next[0]=-1;
        i=0;
        while(i<R)
        {
            while(-1!=j && !same1(i,j))j=next[j];
            next[++i]=++j;
        }
        int ans1=R-next[R];
        j=next[0]=-1;
        i=0;
        while(i<C)
        {
            while(-1!=j && !same2(i,j))j=next[j];
            next[++i]=++j;
        }
        int ans2=C-next[C];
        printf("%d\n",ans1*ans2);
    }
    return 0;
}

 

     

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/p/3154130.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞