POJ 3026 Borg Maze(bfs+最小生成树)

Borg Maze

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6634 Accepted: 2240

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space “ ” stands for an open space, a hash mark “#” stands for an obstructing wall, the capital letter “A” stand for an alien, and the capital letter “S” stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the “S”. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

Source

Svenskt Mästerskap i Programmering/Norgesmesterskapet 2001           一开始一直看不懂题目意思。   关键就是
Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.).      这样其实就是求最小生成树了   先对有A或S的地方进行bfs。得出距离  

//============================================================================
// Name        : POJ.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

char g[100][100];
int n,m;
int a[100][100];
int move[][2]={{1,0},{-1,0},{0,1},{0,-1}};

int cost[110][110];
int t[100][100];
void bfs(int sx,int sy)
{
    queue<pair<int,int> >q;
    while(!q.empty())q.pop();
    memset(t,-1,sizeof(t));
    t[sx][sy]=0;
    q.push(make_pair(sx,sy));
    while(!q.empty())
    {
        pair<int,int> now=q.front();
        q.pop();
        if(a[now.first][now.second]!=-1)
            cost[a[sx][sy]][a[now.first][now.second]]=t[now.first][now.second];
        for(int i=0;i<4;i++)
        {
            int tx=now.first+move[i][0];
            int ty=now.second+move[i][1];
            if(g[tx][ty]=='#'||t[tx][ty]!=-1)continue;
            t[tx][ty]=t[now.first][now.second]+1;
            q.push(make_pair(tx,ty));
        }
    }
}
const int INF=0x3f3f3f3f;
bool vis[110];
int lowc[110];
int Prim(int n)
{
    int ans=0;
    memset(vis,false,sizeof(vis));
    vis[0]=true;
    for(int i=1;i<n;i++)lowc[i]=cost[0][i];
    for(int i=1;i<n;i++)
    {
        int minc=INF;
        int p=-1;
        for(int j=0;j<n;j++)
            if(!vis[j]&&minc>lowc[j])
            {
                minc=lowc[j];
                p=j;
            }
        if(minc==INF)return -1;
        ans+=minc;
        vis[p]=true;
        for(int j=0;j<n;j++)
            if(!vis[j]&&lowc[j]>cost[p][j])
                lowc[j]=cost[p][j];
    }
    return ans;
}


int main()
{
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        gets(g[0]);
        memset(a,-1,sizeof(a));
        int tol=0;
        for(int i=0;i<n;i++)
        {
            gets(g[i]);
            for(int j=0;j<m;j++)
                if(g[i][j]=='A'||g[i][j]=='S')
                    a[i][j]=tol++;
        }
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                if(a[i][j]!=-1)
                    bfs(i,j);
        printf("%d\n",Prim(tol));
    }
    return 0;
}

 

   

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/p/3147031.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞