HDU 2829 Lawrence (斜率DP)

Lawrence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1523    Accepted Submission(s): 671

Problem Description T. E. Lawrence was a controversial figure during World War I. He was a British officer who served in the Arabian theater and led a group of Arab nationals in guerilla strikes against the Ottoman Empire. His primary targets were the railroads. A highly fictionalized version of his exploits was presented in the blockbuster movie, “Lawrence of Arabia”.

You are to write a program to help Lawrence figure out how to best use his limited resources. You have some information from British Intelligence. First, the rail line is completely linear—there are no branches, no spurs. Next, British Intelligence has assigned a Strategic Importance to each depot—an integer from 1 to 100. A depot is of no use on its own, it only has value if it is connected to other depots. The Strategic Value of the entire railroad is calculated by adding up the products of the Strategic Values for every pair of depots that are connected, directly or indirectly, by the rail line. Consider this railroad: 

Its Strategic Value is 4*5 + 4*1 + 4*2 + 5*1 + 5*2 + 1*2 = 49.

Now, suppose that Lawrence only has enough resources for one attack. He cannot attack the depots themselves—they are too well defended. He must attack the rail line between depots, in the middle of the desert. Consider what would happen if Lawrence attacked this rail line right in the middle: 

The Strategic Value of the remaining railroad is 4*5 + 1*2 = 22. But, suppose Lawrence attacks between the 4 and 5 depots: 

The Strategic Value of the remaining railroad is 5*1 + 5*2 + 1*2 = 17. This is Lawrence’s best option.

Given a description of a railroad and the number of attacks that Lawrence can perform, figure out the smallest Strategic Value that he can achieve for that railroad.   

 

Input There will be several data sets. Each data set will begin with a line with two integers, n and m. n is the number of depots on the railroad (1≤n≤1000), and m is the number of attacks Lawrence has resources for (0≤m<n). On the next line will be n integers, each from 1 to 100, indicating the Strategic Value of each depot in order. End of input will be marked by a line with n=0 and m=0, which should not be processed.  

 

Output For each data set, output a single integer, indicating the smallest Strategic Value for the railroad that Lawrence can achieve with his attacks. Output each integer in its own line.  

 

Sample Input 4 1 4 5 1 2 4 2 4 5 1 2 0 0  

 

Sample Output 17 2  

 

Source
2009 Multi-University Training Contest 2 – Host by TJU  

 

Recommend gaojie       很经典的题目。 第二次做了 解释见注释

/*
 * 用dp[i][x]表示前i个点,炸掉x条边可以破坏的最大值
 * 答案就是tol-dp[n][m]
 * dp[i][x]=max{dp[j][x-1]+sum[j]*(sum[i]-sum[j])}  x-1<j<i
 * 假设在计算i时,k<j,j比k点优
 * dp[k][x-1]+sum[k]*(sum[i]-sum[k])<=dp[j][x-1]+sum[j]*(sum[i]-sum[j])
 * 化简得 ( (sum[j]*sum[j]-dp[j][x-1])-(sum[k]*sum[k]-dp[k][x-1]) ) /(sum[j]-sum[k]  <=sum[i]
 *
 * yj=sum[j]*sum[j]-dp[j][x-1]    xj=sum[j]
 * (yj-yk)/(xj-xk)<=sum[i]
 * 右边不等式是递增的
 * g[k,j]=(yj-yk)/(xj-xk)
 * 上述不等式成立说明j比k优
 * 如果k<j<i  g[k,j]>g[i,j]那么k可以淘汰
 * 如果g[j,i]<sum[i]  j可以淘汰
 *
 *
 */

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int MAXN=1010;
int n,m;
int a[MAXN];
int sum[MAXN];
int dp[MAXN][MAXN];
int tol;
int getDP(int i,int x,int j)
{
    return dp[j][x-1]+sum[j]*(sum[i]-sum[j]);
}
int getUp(int j,int x,int k)
{
    return sum[j]*sum[j]-dp[j][x-1]-(sum[k]*sum[k]-dp[k][x-1]);
}
int getDown(int j,int k)
{
    return sum[j]-sum[k];
}
int q[MAXN];
void solve()
{
    memset(dp,0,sizeof(dp));
    int front,rear;
    for(int x=1;x<=m;x++)
    {
        rear=front=0;
        q[rear++]=x;
        for(int i=x+1;i<=n;i++)
        {
            while(front+1<rear && getUp(q[front+1],x,q[front])<=sum[i]*getDown(q[front+1],q[front]))
                front++;
            dp[i][x]=getDP(i,x,q[front]);
            while(front+1<rear && getUp(i,x,q[rear-1])*getDown(q[rear-1],q[rear-2])<=getUp(q[rear-1],x,q[rear-2])*getDown(i,q[rear-1]))
                rear--;
            q[rear++]=i;
        }
    }
    printf("%d\n",tol-dp[n][m]);
}
int main()
{
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    while(scanf("%d%d",&n,&m)==2)
    {
        if(n==0 && m==0)break;
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        tol=0;
        for(int i=n;i>1;i--)
            tol+=a[i]*sum[i-1];
        solve();
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2013/05/08/3067969.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞