HDU 1525 Euclid's Game (博弈)

Euclid’s Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1256    Accepted Submission(s): 576

Problem Description Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7

11 7

4 7

4 3

1 3

1 0 

an Stan wins. 

 

 

Input The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.  

 

Output For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

 

Sample Input 34 12 15 24 0 0  

 

Sample Output Stan wins Ollie wins  

 

Source
University of Waterloo Local Contest 2002.09.28  

 

Recommend LL  

 

题目给出了两个正数a.b

每次操作,大的数减掉小的数的整数倍。一个数变为0 的时候结束。

谁先先把其中一个数减为0的获胜。问谁可以赢。Stan是先手。

 

假设两个数为a,b(a>=b)

 

如果a==b.那么肯定是先手获胜。一步就可以减为0,b

如果a%b==0.就是a是b的倍数,那么也是先手获胜。

如果a>=2*b.  那么 那个人肯定知道a%b,b是必胜态还是必败态。如果是必败态,先手将a,b变成a%b,b,那么先手肯定赢。如果是必胜态,先手将a,b变成a%b+b,b.那么对手只有将这两个数变成a%b,b,先手获胜。

 

如果是b<a<2*b  那么只有一条路:变成a-b,b  (这个时候0<a-b<b).这样一直下去看谁先面对上面的必胜状态。

 

所以假如面对b < a <2*b的状态,就先一步一步走下去。直到面对一个a%b==0 || a >=2*b的状态。

 

#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b) == 2)
    {
        if( a == 0 && b == 0)break;
        if( a < b)swap(a,b);
        int win = 0;
        while(b)
        {
            if( a%b == 0 || a/b >= 2)break;
            a = a-b;
            swap(a,b);
            win ^= 1;
        }
        if(win == 0)printf("Stan wins\n");
        else printf("Ollie wins\n");
    }
    return 0;
}

 

 

 

 

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/p/3204627.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞